Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Liebe Community,

    ich bin langsam echt am verzweifeln. Ich habe mir nun einen "starken" Rechner zusammengebaut, um gemütlich streamen sowie zocken zu können. Nun habe ich ALLE Einstellungen probiert, allerdings läuft der Stream einfach nicht flüssig, und die Frames sehen verworfen aus, obwohl bei Streamlabs OBS keine verworfenen Frames angezeigt werden...

    mein Rechner:

    CPU: i9-10900k
    RAM: 32 GB 3200MHz Corsair Vengeance Pro RGB
    GPU: Strix 2070
    Mainboard: Z490-F Gaming
    AIO: H150i Pro RGB von Corsair

    meine Streameinstellungen:

    Ausgabe: Hardware (NVENC), aber auch x264 probiert - beides Schmutz.
    CBR
    9000 Bitrate (Habe eine 300k Leitung, sollte kein Problem sein)
    Keyframeintervall: auf 0, habe auch iwo gelesen 2 soll gut sein, hat auch nicht funktioniert.
    Voreinstellung: Sowohl Qualität als auch Max-Qualität machen Probleme
    Profile: Main, ebenfalls alles umgeändert.
    GPU: 0 (kA was das ist lol)

    Wenn es euch interessiert, wie das ganze ausschaut, schaut einfach kurz in die Wiederholung meines letzten Streams rein, da ich finde, es ist echt schwer zu beschreiben...



    Ich hoffe so sehr, dass ihr mir helfen könnt. Es macht mich langsam wahnsinnig.

    Liebe Grüße,

    Aldin
  • PownedLP schrieb:

    9000 Bitrate (Habe eine 300k Leitung, sollte kein Problem sein)Keyframeintervall: auf 0, habe auch iwo gelesen 2 soll gut sein, hat auch nicht funktioniert.
    Voreinstellung: Sowohl Qualität als auch Max-Qualität machen Probleme
    Profile: Main, ebenfalls alles umgeändert.
    GPU: 0 (kA was das ist lol)
    Hey, ich versuche mal, ein paar Antworten oder Vorschläge zu geben.

    Hab mir grad dein VOD angeschaut und ich glaube, ich verstehe, was du meinst. Effektiv kommen 60 fps an, aber es sieht aus als würden hin und wieder Frames fehlen.

    Zuerst einmal würde ich die Bitrate auf 6.000 oder 7.000 stellen, um zu checken, ob es dann besser wird. Nur weil deine Leitung das liefert, heißt das leider nicht, dass Twitch das auch live verarbeiten kann. Dein Signal wird an die Twitch-Server geschickt, die das Ganze dann nochmal encoden, damit der Zuschauer alles sehen kann. Blöderweise limitiert Twitch das alles ein wenig, weshalb eigentlich nur 6.000 empfohlen werden. Erfahrungsgemäß klappt es bis 8.000 kbps ganz gut, ab da wird's aber haarig. 9.000 könnten also schon zu viel sein für den Twitch-Encoder ... den du leider nicht beeinflussen kannst. Für die Theorie würde auch sprechen, dass OBS bei dir keine Frames verwirft. Läge es an deinen Settings, dann könntest du das a) in den Statistiken nachvollziehen und/oder b) würdest du es im Game auch selbst merken.

    Abgesehen davon: Keyframeintervall auf 2 ist sinnvoll. Solltest du entsprechend anpassen.
    GPU: 0 gibt den Grafikkarten-Slot an. Das ist nur relevant, wenn du mehrere Grafikkarten nutzen würdest. Dann könntest du GPU: 0 einstellen oder GPU:1 für die zweite Grafikkarte. Also lass es einfach auf 0. Das passt so. :) Die genaue Bezeichnung findest du im Task-Manager unter Leistung. Idealerweise steht deine Haupt-Grafikkarte da bei GPU 0. Falls da der CPU-interne Grafikkarten-Chip drin steht, solltest du das vermutlich wechseln.
  • Game of Jones schrieb:

    PownedLP schrieb:

    9000 Bitrate (Habe eine 300k Leitung, sollte kein Problem sein)Keyframeintervall: auf 0, habe auch iwo gelesen 2 soll gut sein, hat auch nicht funktioniert.
    Voreinstellung: Sowohl Qualität als auch Max-Qualität machen Probleme
    Profile: Main, ebenfalls alles umgeändert.
    GPU: 0 (kA was das ist lol)
    Hey, ich versuche mal, ein paar Antworten oder Vorschläge zu geben.
    Hab mir grad dein VOD angeschaut und ich glaube, ich verstehe, was du meinst. Effektiv kommen 60 fps an, aber es sieht aus als würden hin und wieder Frames fehlen.

    Zuerst einmal würde ich die Bitrate auf 6.000 oder 7.000 stellen, um zu checken, ob es dann besser wird. Nur weil deine Leitung das liefert, heißt das leider nicht, dass Twitch das auch live verarbeiten kann. Dein Signal wird an die Twitch-Server geschickt, die das Ganze dann nochmal encoden, damit der Zuschauer alles sehen kann. Blöderweise limitiert Twitch das alles ein wenig, weshalb eigentlich nur 6.000 empfohlen werden. Erfahrungsgemäß klappt es bis 8.000 kbps ganz gut, ab da wird's aber haarig. 9.000 könnten also schon zu viel sein für den Twitch-Encoder ... den du leider nicht beeinflussen kannst. Für die Theorie würde auch sprechen, dass OBS bei dir keine Frames verwirft. Läge es an deinen Settings, dann könntest du das a) in den Statistiken nachvollziehen und/oder b) würdest du es im Game auch selbst merken.

    Abgesehen davon: Keyframeintervall auf 2 ist sinnvoll. Solltest du entsprechend anpassen.
    GPU: 0 gibt den Grafikkarten-Slot an. Das ist nur relevant, wenn du mehrere Grafikkarten nutzen würdest. Dann könntest du GPU: 0 einstellen oder GPU:1 für die zweite Grafikkarte. Also lass es einfach auf 0. Das passt so. :) Die genaue Bezeichnung findest du im Task-Manager unter Leistung. Idealerweise steht deine Haupt-Grafikkarte da bei GPU 0. Falls da der CPU-interne Grafikkarten-Chip drin steht, solltest du das vermutlich wechseln.
    Hey! Erstmals danke für die schnelle Antwort. Ich habe alle Einstellungen schon probiert.. Erfahrungsgeäß hatte ich auch früher das Problem, dass wenn ich zwei verschiedene Frequenzzahlen bei meinen Monitoren habe, dass diese auch quasi "gebottlenecked" haben... aber jetzt habe ich beide auf 120 Hz gestellt (einer davon eig 165Hz), hat allerdings auch nix geholfen.. :( Sollte ich es vielleicht mit dem normalen OBS probieren?
  • Ja, da gab es früher mal Probleme mit unterschiedlichen Hertz-Zahlen. Das sollte allerdings eigentlich gefixt sein. Du kannst aber mal versuchen, zu schauen ob es mit (oder ohne) Windows-Spielemodus besser klappt. Dürfte aber eigentlich keine Auswirkung haben.

    Der Wechsel zu OBS Studio ist keine schlechte Idee. Probiert’s mal aus. Ich denke aber trotzdem, dass es tendenziell eher an Twitch liegt. Schlecht sieht dein Stream allerdings nicht aus. Wäre für mich absolut zu verkraften, wie es aussieht. Man sieht es eh nur, wenn man massiv drauf achtet, finde ich
  • Game of Jones schrieb:

    Ja, da gab es früher mal Probleme mit unterschiedlichen Hertz-Zahlen. Das sollte allerdings eigentlich gefixt sein. Du kannst aber mal versuchen, zu schauen ob es mit (oder ohne) Windows-Spielemodus besser klappt. Dürfte aber eigentlich keine Auswirkung haben.

    Der Wechsel zu OBS Studio ist keine schlechte Idee. Probiert’s mal aus. Ich denke aber trotzdem, dass es tendenziell eher an Twitch liegt. Schlecht sieht dein Stream allerdings nicht aus. Wäre für mich absolut zu verkraften, wie es aussieht. Man sieht es eh nur, wenn man massiv drauf achtet, finde ich


    Heute mit allen möglichen Einstellungen wieder probiert - selbes Thema....
  • Hm. Naja, ich find's minimal besser so. Insgesamt ist es aber eh nicht so schlimm, wie du hier und in deinem Stream machst, tbh. Entspann dich :) Der Stream sieht gut aus.
    Kannst mal noch "Lookahead" anschalten. Das gleicht die B-Frames automatisch besser an. Geht ein wenig zu Lasten der GPU, aber das sollte bei deiner Grafikkarte eigentlich easy passen. Startest du OBS als Admin? Falls nicht, mach das mal noch.

    Ansonsten wäre es cool, wenn du deine Infos ein wenig besser sortieren würdest. "Alle möglichen Einstellungen" kann halt auch alles sein. ;)
  • Game of Jones schrieb:

    Hm. Naja, ich find's minimal besser so. Insgesamt ist es aber eh nicht so schlimm, wie du hier und in deinem Stream machst, tbh. Entspann dich :) Der Stream sieht gut aus.
    Kannst mal noch "Lookahead" anschalten. Das gleicht die B-Frames automatisch besser an. Geht ein wenig zu Lasten der GPU, aber das sollte bei deiner Grafikkarte eigentlich easy passen. Startest du OBS als Admin? Falls nicht, mach das mal noch.

    Ansonsten wäre es cool, wenn du deine Infos ein wenig besser sortieren würdest. "Alle möglichen Einstellungen" kann halt auch alles sein. ;)
    Es gibt halt wirklich nichts, was ich noch nicht ausprobiert habe. Das mit dem Lookahead lese ich jetzt zum ersten Mal, mal schauen.. und naja ich setze mir selbst sehr hohe Standards, wenns minimale Ruckler gibt, bzw. verworfene Frames, dann stört mich das, weil ich weiß, alle was ich an Equipment habe, MUSS ausreichen, damit ich flüssig in 60 FPS streame... wenn man bedenkt, dass ich mir sogar extra nen neuen Rechner zusammengebaut habe, ist die Belastung gleich doppelt so hoch.
  • Verständlich. Dir muss dennoch klar sein, dass es immer noch Streaming ist. Vor 1,5Jahren war noch 720p mit 30 fps Standard in dem Bereich und viele streamen immer noch mit 720 oder 900p.
    Wenn OBS laut Statistik keine Frames verwirft, dann wird auch nix verworfen. So einfach ist das. Schau dir also (again!) die Statistiken an. Wenn da nichts ist oder unter 1-3 % bleibt, ist alles easy. Dann brauchst du dir eigentlich keine Gedanken machen, weil du alles andere nicht beeinflussen kannst.

    Hand aufs Herz: Die minimalen Mikroruckler fallen nicht auf, wenn man nicht danach sucht und sind mit Abstand das kleinste Problem bei dir. Wirklich! Aber kann gern ja noch wer anderes drüberschauen und was dazu sagen.
  • Servus PownedLP,

    also das hat schon viel mit der Fliege und dem Elefanten zu tun... Spaß bei Seite, das was du da lieferst ist vollkommen in Ordnung und kannst dich ja gern mal bei deinen Streamer Kollegen im Warzone Umfeld umsehen, da ist vieles dabei, das dein Niveau nicht erreicht. Und einen Shooter in flüssigem 1080p60 abzuliefern ist heutzutage immer noch nicht easy. Da fahren die großen Streamer 2 PC Setups, um so etwas hinzubekommen. Wie es mir scheint, sind deine Settings in Game auch nicht besonders beschränkt.

    Ich würde dir auch empfehlen, die Bit Rate runterzusetzen, du schickst viel mehr als Twitch überhaupt verarbeitet. Und es kann nicht Schaden einfach mal OBS Studio zu testen, da fällt schon mal viel Schnickschnack weg.

    Und wie @Game of Jones schon gesagt hat, wenn dir OBS nicht anzeigt, dass du Frames verlierst, passt an deinem Ende alles und es liegt wahrscheinlich an Twitch. Kannst ja mal ein paar verschiedene Server testen, vielleicht hast du einen erwischt, bei dem die 9000 gar nicht ankommen.

    Hier kannst du nachschauen was wirklich ankommt: https://inspector.twitch.tv/
    Cbaoth

    Hobbystreamer, Teilzeitgamer, Vollzeitbrot

    twitch.tv/dasoberbrot