Stream lagt/ruckelt - Einstellungen ?

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Moin Leute,

    ich würde gerne mit dem streamen anfangen und habe gestern den ersten Testlauf gehabt, nur hatte ich leichte Lags im Stream und totale
    FPS Drops im Spiel. Grundsätzlich packt mein Rechner eigentlich die meisten Spiele - vielleicht habe ich falsche Einstellungen :hmm: No Front
    gegen den Rechner :psst:

    PC Specs:
    • Intel Core i5-9600K, 6x 3.70 GHz
    • ASUS Prime Z390-A, S. 1151
    • Nvidia GeForce GTX1660 6GB
    • 16GB Corsair Vengeance DDR4-3000
    • 256GB ADATA Ultimate
    • 1000GB Samsung 860 Evo 2.5
    Ich spiele hauptsächlich Fortnite mit 160 FPS und 2 Monitoren a 144 Hz.

    Bei Streamlabs OBS habe ich eine Bitrate von 6000 eingestellt und Prozessorauslastung auf "veryfast" . Die Szene ist auf Game Capture gestellt.
    Keyframeintervall auf 2. Enconder auf Hardware (NVENC). Video ist gestellt auf 1280x720 bei 60 FPS.

    Freue mich über eure Hilfe :drooling:

    LG Sethix

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Sethix ()

  • Sethix schrieb:

    Moin Leute,

    ich würde gerne mit dem streamen anfangen und habe gestern den ersten Testlauf gehabt, nur hatte ich leichte Lags im Stream und totale
    FPS Drops im Spiel. Grundsätzlich packt mein Rechner eigentlich die meisten Spiele - vielleicht habe ich falsche Einstellungen :hmm: No Front
    gegen den Rechner :psst:

    PC Specs:
    • Intel Core i5-9600K, 6x 3.70 GHz
    • ASUS Prime Z390-A, S. 1151
    • Nvidia GeForce GTX1660 6GB
    • 16GB Corsair Vengeance DDR4-3000
    • 256GB ADATA Ultimate
    • 1000GB Samsung 860 Evo 2.5
    Ich spiele hauptsächlich Fortnite mit 160 FPS und 2 Monitoren a 144 Hz.

    Bei Streamlabs OBS habe ich eine Bitrate von 6000 eingestellt und Prozessorauslastung auf "veryfast" . Die Szene ist auf Game Capture gestellt.
    Keyframeintervall auf 2. Enconder auf Hardware (NVENC). Video ist gestellt auf 1280x720 bei 60 FPS.

    Freue mich über eure Hilfe :drooling:

    LG Sethix
    Kannst du mal Screenshots deiner Einstellungen schicken? (Video, Ausgabe)
    und deiner Qullensammlung.

    Wenn du über NVENC streamst sollte es keine "Prozessorauslastung" zum auswählen verfügbar sein.
    Du suchst ein neues Logo für deinen Stream?
    Dann schau mal hier vorbei. :]
    Fiverr - Minimalist and Modern Logo
  • Natürlich :) Habe noch an der ein oder anderen Stelle etwas umgeändert und der Stream läuft flüssiger, jedoch kann ich die FPS Drops nicht umgehen.
    Bilder
    • 1.png

      43,96 kB, 830×802, 71 mal angesehen
    • 2.png

      55,69 kB, 827×802, 63 mal angesehen
  • Daikota schrieb:

    Wenn deine CPU dauerhaft auf 100% ist, dann ist es kein Wunder das der Stream nicht flüssig läuft.

    Das ungefähr so als wenn du einen Milchshake trinkt und dabei die ganze Zeit 100% in die Pedale trittst auf deinem Fahrrad
    Ist mir gar nicht aufgefallen. Verstehe nur nicht warum das Spiel bitte 80% zieht ..
  • Naja, es kommt stark auf das Spiel an, ob man es mit einem PC gleichzeitig Zocken & Streamen kann. Das Streamen alleine braucht schon gut Leistung vom PC. Wenn das Spiel dann auch noch sehr Hardwarehungrig ist, wird es eng...
    Damals als ich noch mit 1 PC beides gemacht habe, hatte ich z.B bei Sea of Thieves keine Probleme. Das Spiel lief Butterweich & der Stream sah 1 Sahne aus! Als ich dann The Division zocken & Streamen wollte, sah es schon anders aus. Deshalb bin ich dann auf ein 2 PC Setup geswichted.

    MFG - Floooo

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Floooo ()

  • Floooo schrieb:

    Naja, es kommt stark auf das Spiel an, ob man es mit einem PC gleichzeitig Zocken & Streamen kann. Das Streamen alleine braucht schon gut Leistung vom PC. Wenn das Spiel dann auch noch sehr Hardwarehungrig ist, wird es eng...
    Damals als ich noch mit 1 PC beides gemacht habe, hatte ich z.B bei Sea of Thieves keine Probleme. Das Spiel lief Butterweich & der Stream sah 1 Sahne aus! Als ich dann The Division zocken & Streamen wollte, sah es schon anders aus. Deshalb bin ich dann auf ein 2 PC Setup geswichted.

    MFG - Floooo
    Ich denke ein Spiel wie SoT oder WoW sollte einwandfrei laufen, nur bei Shootern wird es schwierig. An Warzone brauch ich gar nicht denken.

    Einen zweiten PC dafür anzuschaffen kommt für mich actually nicht in Frage, da ich erst angefangen habe. Angenommen in einem Monat war´s das, dann ist das Geld auch weg ||
  • Moin,

    mit deinem System ist es durchaus möglich, in der "besten" Qualität zu streamen. Auch wenn CPU/ GPU voll ausgelastet sein sollten.

    Probiere erstmal folgendes:

    • wenn möglich lieber OBS Studio oder für mehr Funktionen OBS Live nutzen (macht es leichter dir zu helfen)
    • Windows 10 auf Version 2004 updaten
    • Windows Spielmodus aktivieren
    • OBS immer als Administrator ausführen
    Diese Einstellungen nutzen:



    Ein guter Wert für die Ausgabe-Auflösung wäre z. B. 1600x900.

    Bei (FPS) Problemen ggf. Voreinstellung auf "Qualität" und "Psycho Visual Tuning" deaktivieren (sollte nur Einfluss auf die GPU haben).
    Treten weiterhin Probleme auf, die Vorschau in OBS deaktivieren und ggf. OBS minimieren.

    Gruß
    Zitrone

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von ziTR_ONE ()

  • ziTR_ONE schrieb:

    Moin,

    mit deinem System ist es durchaus möglich, in der "besten" Qualität zu streamen. Auch wenn CPU/ GPU voll ausgelastet sein sollten.

    Probiere erstmal folgendes:

    • wenn möglich lieber OBS Studio oder für mehr Funktionen OBS Live nutzen (macht es leichter dir zu helfen)
    • Windows 10 auf Version 2004 updaten
    • Windows Spielmodus aktivieren
    • OBS immer als Administrator ausführen
    Diese Einstellungen nutzen:



    Ein guter Wert für die Ausgabe-Auflösung wäre z. B. 1600x900.

    Bei (FPS) Problemen ggf. Voreinstellung auf "Qualität" und "Psycho Visual Tuning" deaktivieren.
    Treten weiterhin Probleme auf, die Vorschau in OBS deaktivieren und ggf. OBS minimieren.

    Gruß
    Zitrone
    Moin Zitrone,

    danke für die Antwort und dein Follow :P . Ich habe mal OBS Live getestet mit deinen Einstellungen. Es macht von der CPU Auslastung und den Drops tatsächlich keinen Unterschied zu Streamlabs.

    Dann hab ich einige Einstellungen bei Windows im Energiesparmodus auf Höchstleistung umgestellt und bei Nvidia GeForce Experience in den Spieleinstellungen komplett auf Performance,
    wobei die sowieso meinen Spieleinstellungen bereits entsprachen.

    Es läuft nun etwas flüssiger, jedoch droppt es trotzdem zwischenzeitlich von 160 auf 80 je nach Spielsituation. Egal ob OBS oder Streamlabs - mehr Einstellungen kann ich nicht vornehmen.

    Also wohl ne neue CPU oder einen extra Rechner. Die 100%ige Auslastung wird der CPU wohl auf Dauer nicht gut tun..
  • Wie gesagt, 100% Auslastung ist mit den richtigen Einstellungen kein großes Problem.

    Bist du alle Punkte von mir durchgegangen?

    Wenn du jetzt OBS Live hast, mach mal bitte folgendes:

    1. Einstellungen in OBS Live übernehmen.
    2. Stream für mindestens 30 Sekunden starten.
    3. Stream beenden.
    4. In OBS Live: oben in der Leiste auf Hilfe -> Protokolldateien -> letzte Protokolldateien hochladen. Du kommst dann einen Link von OBS. Den bräuchte ich.

    EDIT: Den Link am besten so zerhacken, dass der nicht mehr als Link erkannt wird, sonst wird du, als neuer Account, ggf. erstmal vom Anti-Spam-Bot gesperrt.
  • ziTR_ONE schrieb:

    Wie gesagt, 100% Auslastung ist mit den richtigen Einstellungen kein großes Problem.

    Bist du alle Punkte von mir durchgegangen?

    Wenn du jetzt OBS Live hast, mach mal bitte folgendes:

    1. Einstellungen in OBS Live übernehmen.
    2. Stream für mindestens 30 Sekunden starten.
    3. Stream beenden.
    4. In OBS Live: oben in der Leiste auf Hilfe -> Protokolldateien -> letzte Protokolldateien hochladen. Du kommst dann einen Link von OBS. Den bräuchte ich.

    EDIT: Den Link am besten so zerhacken, dass der nicht mehr als Link erkannt wird, sonst wird du, als neuer Account, ggf. erstmal vom Anti-Spam-Bot gesperrt.


    Wieso soll er OBS benutzen?

    100% CPU/GPU Auslastung ist immer ein Problem. Allein für die Gesundheit der GPU und CPU.
    Wenn du mit deinem Auto maximal geschwidnigkeit fährst geht es dadurch auch irgendwann kaputt.
    Wenn du dann noch zwischendurch einen Berg hoch musst und keine Kraft mehr da ist. Bleibt die Geschwindigkeit auch nicht die selbe.
    Du suchst ein neues Logo für deinen Stream?
    Dann schau mal hier vorbei. :]
    Fiverr - Minimalist and Modern Logo
  • OBS Studio/ Live bietet dank Protokolldateien und detailliert Statistik viel bessere Möglichkeiten fast alle relevanten Einstellungen zu überprüfen.

    Man kann doch CPU oder Grafikkarte nicht mit einem Auto vergleichen. 8|
    Beide Komponenten sind für 100% Auslastung ausgelegt.
    Bei der CPU kommt das bei Gaming/ Streaming recht selten vor, die GPU allerdings läuft bei vielen aktuellen Spielen, gerade auf höheren Auflösungen, permanent am Limit. Das ist vollkommen normal und unbedenklich.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ziTR_ONE ()

  • Kurz Off-Topic

    Daikota schrieb:

    100% CPU/GPU Auslastung ist immer ein Problem. Allein für die Gesundheit der GPU und CPU.
    Wenn du mit deinem Auto maximal geschwidnigkeit fährst geht es dadurch auch irgendwann kaputt.
    Wenn du dann noch zwischendurch einen Berg hoch musst und keine Kraft mehr da ist. Bleibt die Geschwindigkeit auch nicht die selbe.

    Die CPU (Elektronik) wird durch die Temperatur gekillt und nicht durch 100% Auslastung.
    Deine CPU stirbt auch bei 1% Auslastung aber ner Temperatur von 120°C.
    Läuft aber ohne Probleme bei 100% Auslastung und 60°C, es kommt halt nur zu Lags, weil die CPU keine Ressourcen für andere Dinge frei hat.

    Es nutzt sich bei der CPU ja auch nichts ab wie bei einem Auto, das einzige Bauteil, das bei 100% schneller versagen wird, wird wohl der Lüfter sein, da der dauerhaft mit maximalen Umdrehungen dreht...
  • ziTR_ONE schrieb:

    Wie gesagt, 100% Auslastung ist mit den richtigen Einstellungen kein großes Problem.

    Bist du alle Punkte von mir durchgegangen?

    Wenn du jetzt OBS Live hast, mach mal bitte folgendes:

    1. Einstellungen in OBS Live übernehmen.
    2. Stream für mindestens 30 Sekunden starten.
    3. Stream beenden.
    4. In OBS Live: oben in der Leiste auf Hilfe -> Protokolldateien -> letzte Protokolldateien hochladen. Du kommst dann einen Link von OBS. Den bräuchte ich.

    EDIT: Den Link am besten so zerhacken, dass der nicht mehr als Link erkannt wird, sonst wird du, als neuer Account, ggf. erstmal vom Anti-Spam-Bot gesperrt.
    Ja, die Einstellungen entsprechen deinen Punkten.

    OBS Logs

    Ich könnte doch die CPU einfach übertakten, dann sollte sich die Auslastung doch verringern ?
  • Ich glaube kaum das es sich lohnt zu übertakten, da das Leistungsplus, das du da rausholst nicht die CPU-Last von OBS kompensieren kann. Außerdem benötigst du hier wieder eine sehr gute Kühlung und du musst wissen was du tust, da sonst A) dein System instabil läuft oder du B) deine Hardware killst.

    Löse also dein aktuelles Problem nicht an der falschen Stelle, sondern finde die Ursache und behebe diese.
    Ich streame mit einem i7-4790k und einer RTX2060 und habe absolut keine Frame Drops. Deine CPU ist stärker als meine, von daher würde ich pauschal davon ausgehen , dass du nicht die CPU übertakten musst und auch solltest.

    Wie sind denn deine Auslastungen im Taskmanager OHNE OBS und Streaming?


    Ich würde Testweise mal nur in 60FPS spielen und OBS einschalten, um zu sehen wie sich die 60FPS vs 160FPS verhalten, dann kannste den Punkt schonmal ausschließen. Hier ebenfalls mal schauen was die CPU macht.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ShadowRap411 ()

  • Ich bin echt kein Profi, was die OBS Logs angeht, aber für mich sieht das nicht so aus als wäre OBS ein Problem, sondern eher die Tatsache, dass du Fortnite in einer Qualität spielen willst, die dein Rechner halt nicht hergibt. Rendering Lag und Encoding lag sind unter 1 %, was jetzt nicht viel ist. Aber der Test lief auch nicht so lange, vermute ich mal.

    Zumindest nicht, wenn du gleichzeitig streamen willst. Laut UserBenchmark solltest du mit der Karte im Schnitt eh nur auf um die 100 FPS kommen. Dass du so viele packst, ist echt Glück und an deiner Stelle würde ich die eher manuell auf einem bestimmten Wert drosseln. Denn wenn der Grafikspeicher mal voll ist, ist er halt voll. Wenn du mehr Frames im Game willst, führt wohl kein Weg dran vorbei, dir eine bessere Grafikkarte zu holen. Sorry. :(
  • ShadowRap411 schrieb:

    Ich glaube kaum das es sich lohnt zu übertakten, da das Leistungsplus, das du da rausholst nicht die CPU-Last von OBS kompensieren kann. Außerdem benötigst du hier wieder eine sehr gute Kühlung und du musst wissen was du tust, da sonst A) dein System instabil läuft oder du B) deine Hardware killst.

    Löse also dein aktuelles Problem nicht an der falschen Stelle, sondern finde die Ursache und behebe diese.
    Ich streame mit einem i7-4790k und einer RTX2060 und habe absolut keine Frame Drops. Deine CPU ist stärker als meine, von daher würde ich pauschal davon ausgehen , dass du nicht die CPU übertakten musst und auch solltest.

    Wie sind denn deine Auslastungen im Taskmanager OHNE OBS und Streaming?


    Ich würde Testweise mal nur in 60FPS spielen und OBS einschalten, um zu sehen wie sich die 60FPS vs 160FPS verhalten, dann kannste den Punkt schonmal ausschließen. Hier ebenfalls mal schauen was die CPU macht.
    Stimmt auch wieder. Ich hab dir die Bilder angehängt. Es sieht stark danach aus, dass es an der FPS Einstellung liegt. Sobald ich auf 60 FPS stelle und OBS läuft habe ich keine Drops und eine Auslastung von max. 60%.

    Wie kriege ich es nun hin mehr FPS zu halten :hmm:

    Game of Jones schrieb:

    Ich bin echt kein Profi, was die OBS Logs angeht, aber für mich sieht das nicht so aus als wäre OBS ein Problem, sondern eher die Tatsache, dass du Fortnite in einer Qualität spielen willst, die dein Rechner halt nicht hergibt. Rendering Lag und Encoding lag sind unter 1 %, was jetzt nicht viel ist. Aber der Test lief auch nicht so lange, vermute ich mal.

    Zumindest nicht, wenn du gleichzeitig streamen willst. Laut UserBenchmark solltest du mit der Karte im Schnitt eh nur auf um die 100 FPS kommen. Dass du so viele packst, ist echt Glück und an deiner Stelle würde ich die eher manuell auf einem bestimmten Wert drosseln. Denn wenn der Grafikspeicher mal voll ist, ist er halt voll. Wenn du mehr Frames im Game willst, führt wohl kein Weg dran vorbei, dir eine bessere Grafikkarte zu holen. Sorry. :(

    Also grundsätzlich spiele ich auf keiner hohen Qualität (s. Anhang). Ich kann ohne "Stream" mit 160 FPS ohne Probleme spielen. Es ist halt schon ein Unterschied, ob ich mit 60 oder 144 FPS spiele also drosseln wäre schwachsinnig.
    Bilder
    • 1.png

      142,18 kB, 967×1.071, 52 mal angesehen
    • 2.png

      158,28 kB, 965×1.073, 48 mal angesehen
    • Mit OBS - 60 FPS.png

      39,07 kB, 699×681, 49 mal angesehen
    • Ohne OBS - 60 FPS.png

      50,21 kB, 700×680, 50 mal angesehen
    • Ohne OBS - 144 FPS.png

      46,93 kB, 700×682, 50 mal angesehen
    • Ohne OBS 1 - 144 FPS.png

      57,68 kB, 700×682, 49 mal angesehen
  • Habe mir jetzt mal dein Log angeschaut. Grundsätzlich sieht alles gut aus, es gibt aber ein paar Kleinigkeiten, die mich etwas verwundern:

    • Im Log fehlt die Zeile "Game Mode" komplett, was bedeutet, dass OBS dem Registry-Eintag dafür nicht finden konnte. Ist der Spielmodus bei dir wirklich aktiv?
    • Windows 10 ist noch nicht auf 2004 geupdatet, was aber eigentlich nur ein Problem sein sollte, wenn deine Monitore verschiedene Hz-Raten hätten.
    • Deine beiden 144 Hz Monitore scheinen nur auf 60 Hz zu laufen.
      Lösung in der NVIDIA Systemsteuerung:

    • Du hast extrem viele Browser Quellen in deiner aktiven Szene. Test nochmal mit nur einer Spielaufnahme.
      Damit du nicht alles löschen musst, kannst du oben in der OBS Leiste über "Szenensammlung" eine neue, leere erstellen.


    Prinzipiell sollte OBS + Gaming auch mit voll ausgelasteter CPU/ GPU ohne Frame-Drops funktionieren.

    Ansonsten:

    ziTR_ONE schrieb:

    Bei (FPS) Problemen ggf. Voreinstellung auf "Qualität" und "Psycho Visual Tuning" deaktivieren (sollte nur Einfluss auf die GPU haben).
    Treten weiterhin Probleme auf, die Vorschau in OBS deaktivieren und ggf. OBS minimieren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ziTR_ONE ()