Stream laggt (nur Bild), keine geskippten Frames in SLOBS

  • Moin,

    ich bin ein bisschen am Verzweifeln. Meine Zuschauer sagen mir immer wieder, dass das Bild vom Stream stehen bleibt (gerade bei Action-szenen, bei denen etwas mehr los ist auf dem Bildschirm), der Ton jedoch ganz normal weiterläuft.
    Mein Internetprovider hat gesagt, es gäbe keine Störung auf meiner Leitung und auch keine Paketverluste. Das Spiel läuft auf meinem Gamingrechner vollkommen flüssig und der Streamingrechner zeigt bei Streamlabs OBS keine geskippten Frames und ne CPU-Auslastung von nur ca. 10% an beim Stream. Auch auf dem zweiten Monitor sieht alles gut aus.
    Twitch Inspektor spuckt das hier aus: https://imgur.com/qcIwATb
    Auflösung bei Streamlabs ist 1280x720 bei 60FPS und 4500 Bitrate, Software (x264) Encoder (weil extra rechner mit Prozessor dafür) mit medium CPU-Auslastung.

    Muss ich die CPU-Auslastung hochschrauben? Gibt es irgendwas offensichtliches was ich übersehe?

    Wäre wirklich für jede Hilfe dankbar :)



    Kleines Update vom neusten Stream: Das Problem kommt tatsächlich immer dann vor, wenn besonders viel Action in Kämpfen ist oder in Zwischensequenzen. Hab für den Stream auch die CPU Auslastung auf SLOW gestellt - ohne Besserung.


    Ist es dann doch der Upload? Hab eine 250er Leitung mit 24 mbits Upload. Das sollte eigentlich weit mehr als genug dafür sein oder?

  • Danke schonmal für die schnelle antwort :)


    Ich benutze Streamlabs OBS, da hab ich glaub ich als einzige Statistik unten die CPU auslastung, FPS und dropped frames drin. Die waren während des Streams so bei 10% CPU-Auslastung, durchgehen 60 FPS und 2% Frames dropped.

    Das VOD hat die Stopper auch drin. Bild friert komplett ein, Sound wird weiter normal übertragen. Immer für ein paar Sekunden.


    Wenn es der Encoder ist, reicht es dann vllt schon die CPU auslastung auf slow oder slower zu stellen? Genug Kapazität scheint bei der CPU ja aufjedenfall noch zu sein

  • Kleines Update vom neusten Stream: Das Problem kommt tatsächlich immer dann vor, wenn besonders viel Action in Kämpfen ist oder in Zwischensequenzen. Hab für den Stream auch die CPU Auslastung auf SLOW gestellt - ohne Besserung.


    Ist es dann doch der Upload? Hab eine 250er Leitung mit 24 mbits Upload. Das sollte eigentlich weit mehr als genug dafür sein oder?

  • Sagt mir leider gar nichts. In der Taskleistenecke ist nur "NVIDIA Einstellungen". Ist das Aufnahme Programm automatisch bei Streamlabs dabei oder wo würde ich das finden?

    Automatisch von Nvidia, wenn du die Software zum updaten hast, was du definitiv immer aktuell halten solltest.

    Wer seine Grafikkarte nicht updatet, bekommt immer wieder Probleme und laggs. :P

  • Update vom neusten Stream. Ich hab vorher alle Treiber aktualisiert, Firewall für Streamlabs OBS freigegeben und geguckt, dass kein Nvidia Aufnahmeprogramm läuft.


    Der Stream lief lange gut (siehe Grafik im Post vorher) aber am Ende kamen wieder erste Framedrops bis es am Ende wieder unerträglich wurde. Am Gamingrechner lief alles flüssig und im Kontrollbild vom Streamingrechner auch.

    Die gesamte Zeit wurde ein- und dasselbe Spiel gestreamt.


    Ich bin echt am verzweifeln.

    Kann das ein Hitzeproblem sein? Ist das ein Internetproviderproblem?


    Da muss es doch ne Lösung für geben.


    (Hatte den Text eben schon geschrieben aber wurde gelöscht beim Post vorher)

  • Ich würde auf das Internet schließen. Da die Min. Bitrate bei 200 liegt, lese ich da jetzt raus, dass deine Bitrate drastisch runtegegangen ist an manchen Stellen.

    Allerdings traue ich dem Twitch Inspector auch nicht zu 100%, da der das teilweise nur sehr langsam registriert, wenn man Frames dropped. (Eigene Erfahrung.)


    Genaueres könnte man sagen, wenn du stattdessen OBS Studio verwenden würdest, da hier die Statistiken deutlich aussagekräftiger sind und man genau nachvollziehen kann, ob die Framesdrops durch Netzwerkfehler oder beim Encoden kommen. (Vielleicht ziehst du den Wechsel auch aufgrund des neusten Streamlabs-"Skandals" in Betracht.)

  • Andere Frage :D Wohnst du in einem Hausblock mit mehreren Parteien?

    Ja wohn ich tatsächlich. Ich bin über Vodafone Kabel drin falls das relevant ist für die Hausblock-Theorie :D


    (Vielleicht ziehst du den Wechsel auch aufgrund des neusten Streamlabs-"Skandals" in Betracht.)

    Oh, davon hab ich tatsächlich gar nichts gehört. Was ist denn passiert?

    Und gibt es eigentlich irgendeinen Grund der für Streamlabs OBS spricht im Vergleich zu "normal" OBS? Weil ich sonst tatsächlich mal wechseln würde.

  • Externer Inhalt www.youtube.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.


    Das beantwortet immerhin die Skandal Frage ^^

  • gomlord In der Regel bessere Performance, kostenfreier Plugin-Support und bessere bzw. aussagekräftigere Statistiken. Das sind so die Hauptgründe. Unabhängig von dem ganzen anderen Kram, den sich Streamlabs seit Jahren leistet. Der aktuelle „Skandal“ ist eigentlich nur der Gnadenstoß für ein Projekt, das auf dreiste Weise aus Ideenklau ne Cashcow gemacht hat.


    OBS Studio ist nicht so einsteigerfreundlich, aber du hast die komplette Kontrolle. Und das kostenfrei.


    Zum Thema: sieht für mich auch sehr nach Netzwerk-Problemen aus. In OBS Studio mal unter Ansicht Statistiken einschalten. Dann streamen und mit den Infos in dem Fenster können wir dir gezielt weiterhelfen. :)

  • Ja wohn ich tatsächlich. Ich bin über Vodafone Kabel drin falls das relevant ist für die Hausblock-Theorie :D

    Kabel Deutschland verbaut in Wohnblöcken eine Zentrale im Keller, d.h. das im gesamten Haus,

    jeder diese Leitung verwendet.


    Ich habe dieses Phänomen Tatsache bei einer Freundin erlebt, Tagsüber konnte sie ohne Probleme streamen,

    doch gerade immer Abends, wenn viele Menschen daheim waren.

    Hat es das laggen angefangen.


    Kann sein das die Leitungen alt sind, oder der Verteiler im Keller alt ist,

    mache doch mal einen Speedtest deines Internets heute Abend

  • Es ist mal wieder Zeit für ein Update :P


    Ich hab einiges umgestellt zum letzten Stream. Statt Streamlabs hab ich alles bei OBS Studio eingerichtet, dort dann den Server in Berlin direkt ausgewählt, da der beim TwitchTest die höchste Qualität und Bandbreite und geringste Verzögerung hatte.


    Statt meinem Internet von Vodafone über Kabel hab ich von einem Bekannten einen LTE-Router geliehen bekommen und darüber gestreamt (aber über WLAN).



    Am Ende hat OBS Studio in den statistics das hier ausgespuckt:


    Und TwitchInspektor das hier:



    Es gab also wieder 4 Momente, in denen es Framedrops gab, jedoch waren es weniger als sonst.

    So wie ich das sehe sind also alle ausgelassenen Frames aufgrund des Internets und in diesem Fall vllt weil der LTE-Router nicht 100% zuverlässig ist?

    Mich würde interessieren ob ihr das auch so seht.



    Kann sein das die Leitungen alt sind, oder der Verteiler im Keller alt ist,

    mache doch mal einen Speedtest deines Internets heute Abend

    Bei Speedtests komme ich immer auf super hohe und gute Werte, egal wann und egal wo ich die mache. Die Störungen sind ja auch immer sehr punktuell und die Leitung ist nicht dauerhaft schlecht.

  • Woran das jetzt ganz konkret liegt, kann ich nicht mit Sicherheit sagen … was man aber gut sieht, ist, dass es zu 100 % am Internet liegt. Bei den anderen Bereichen hast du keine Frame-Verluste, sondern nur im Bereich Netzwerk. Somit kannst du deine Hardware grundsätzlich als Fehlerquelle ausschließen, was gut ist. :)

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!