Streamlabs OBS Lags und zucken bei Cod Cold War

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo zusammen,

    ein Problem was ich noch nie hatte und es ist egal was ich einstelle, es wird nicht besser. Vielleicht kann hier mir jemand helfen.





    CPU: AMD Ryzen 9 3900X 12-Kern (12x3.8 GHz)
    Mainboard: MSI MPG X570 Gaming Edge WiFi
    RAM: Corsair Vengeance LPX 32GB DDR4 3200MHz
    GPU: NVIDIA GeForce GTX 1080 OC
    Festplatte: Corsair Force MP510 960 GB M2-SSD
    Display 1: Asus VG248QE
    Display 2: Samsung SyncMaster 2433

    Internet:
    200.000 download
    200.000 Upload (Ja es ist wirklich so viel ;) )

    Alle Treiber sind aktuell.

    Das Lustige ist, bei mir im Spiel ist alles super flüssig (90 - 130 FPS) nur der Stream Laggt und zuckt. Allerdings auch nur bei Cold War. Modern Warfare läuft sauber schmatzend.



    Ich hoffe mir kann da einer helfen!!!

    Lieben Gruß
  • Moin @Burning85,

    du schreibst zwar, du hättest alles versucht aber manchmal gibt es doch noch kleine Dinge, die man nicht direkt auf dem Schirm hat ;)

    Bitte Probiere mal folgende Sachen:

    • Encoder Hardware (NVENC) (new)
    • Anwendung als Administrator starten (Streamlabs OBS und ggf. Cold War)
    • Mit dem Taskmanager auch mal die GPU Auslastung im Auge behalten
    • Als Quelle Bildschirm-Aufnahme, Spiel-Aufnahme und Fenster-Aufnahme


    Vielleicht hilft dir einer der Punkte um das Problem zu beheben oder einzugrenzen.
    Mir hatte z.B der 2 Punkt (Anwendung als Administrator starten) enorm geholfen bei ein paar Spielen die sich auch nicht Capturen ließen.

    Ich wünsche dir viel Erfolg beim Lösen!


    ~Stöpsel~
  • Ich habe auch den Ryzen 3900x und nutze eine RTX 2070.
    Bei mir ist es so, dass ich mit dem x264 bessere Erfolge habe, als mit dem NvencNew.
    Bei mir habe ich auch laggs wenn ich über Nvenc es probiere.
    Ich kann die x264 Einstellung schon verstehen (der Prozessor packt es ja).

    Bei mir waren es aber bislang immer folgende Punkte.
    - Hz vom Monitor! Bei meinem 144Hz Monitor musste ich auf 120Hz stellen (vielfaches von 60 FPS), da die 144Hz ungerade Werte für den Codec ergeben.
    Hz ist wie FPS zu sehen und sollten gleich oder ein vielfaches von der gewünschten Ausgabe-FPS entsprechen.
    - FPS im Spiel auf 60 FPS limitieren. Unbegrenzt oder auch 120FPS Limit führen bei mir zu laggs. COD stellt (zumindest bei mir) oft von alleine die Grafikeinstellungen Hz und FPS sowie Vollbild um beim Starten um.
    - Raytracing deaktivieren. OBS arbeitet noch mit DX11. Raytracing allerdings mit DX12. Das kann evtl. dazu führen, das OBS Fehler verursacht.
    - OBS und Spiele auf verschiedene Kerne zuweisen. Ich benutzte Lasso, um Spiele auf den ersten 6 Kernen laufen zu lassen und OBS auf den anderen bzw. einen Teil der anderen.

    Ich denke dass die Hz und FPS bei dir das Problem sind. Das was deine Videos zeigen, kommt mir bekannt vor.

    Die 4 Vorschläge von CommandoStoepsel sind ebenfalls zu beachten. Vor allem das mit "als Admin starten".
    Ich füge aber noch hinzu, bei den Szenen bitte niemals Bildschirmaufnahme und Gameaufnahme gleichzeitig als Quelle drin zu haben.
    Auch nicht wenn eines davon deaktiviert ist. Es wird zwar nicht gezeigt aber trotzdem in Hintergrund erfasst.

    Das wären so meine Punkte, wo es bei mir immer dran gelegen hat. Auch zuletzt mit Cold War.
  • Erst einmal vielen Dank für die schnelle Hilfe!


    @Stöpsel

    Punkt 1 - habe ich auch schon probiert = Kein Erfolg (wusste ich aber schon vorher, darum habe ich mir den 3900x geholt )
    Punkt 2 – Versuche ich gleich mal
    Punkt 3 – Versuche ich gleich mal
    Punkt 4 – Video 1 ist mit Bildschirm-Aufnahme und Video 2 ist mit Spiel-Aufnahme


    @Toastfalter

    Die Vermutung mit der 144 hz hatte ich auch. Leider erfolglos, wenn ich an den FPS rumspiele. (Bei Odyssey und Valhalla war das die Lösung.

    Ich versuche Lasso mal und werde berichten.

    Update


    Nachdem ich Lasso und die FPS auf 60 gestellt habe, und mein OBS auf medium statt veryfast, läuft alles traumhaft. Vielen lieben Dank

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Burning85 ()