Stream bricht ab

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren



Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hi zusammen !

    Ich habe seit meinem Internetupgrade angefangen Warcraft3 zu streamen. Der Stream läuft soweit und die Qualli ist größtenteils in Ordnung. Zumindest meinen Anforderungen genügend ;)

    Ingame merke ich nichts, alles läuft flüssig, soweit so gut. Jetzt habe ich das Problem, das in unregelmäßigen Abständen mein Stream ausgeht. Das bekomme ich allerdings nur mit wenn ich auf der Twitch Seite nebenher gucke wenn mein Stream auf einmal offline ist.

    Ich benutze Streamlabs OBS, in der Software sieht alles unverändert aus und die "Live Zeit" läuft normal weiter innerhalb der Software. Auch der Button "Stream beenden" ist unten angezeigt, statt "Stream starten". also es sieht alles aus als würde der Stream normal weiterlaufen, was allerdings nicht der Fall ist.

    Jmd. eine Idee ?

    Grüße
  • Moin erstmal, mit was für ein Endgerät schaust du ob dein stream ordentlich läuft? Handy Vielleicht ? Da kann es nämlich manchmal vorkommen das dann da steht das der Stream offline ist, was er aber nicht ist. Speicherst du bei Twitch deine letzten Streams ? Wenn ja schau doch Mal ob bei den Zeiten wo es als offline angezeigt wurde alles in Ordnung war. Mfg Bandit
  • Hi, danke erstmal für die Antworten.

    Also bekomme das Feedback auch von meinen paar Viewern, dass der Stream offline geht. Sehe es selber im Browser ebenfalls.

    Meine Streams speicher ich nicht.


    Auf die Bitrate muss ich mal achten. Meine Leitung ist relativ gut, 11.000 kbit/s. Streame mit ner 6000 Bitrate. Muss dazu sagen das meine Hardware eher mau ist. Ingamae läuft alles super, Stream soweit auch aber kann es sein das es trotzdem zuviel für die Hardware wird und es sich dann abstellt ?


    Achja, ich Stream mit dem NVENC (NEW) encoder. Evtl. doch lieber über den CPU gehen ?
    Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von pogige ()

  • Also zum einen kommt es darauf an was du streamst. Streamst du spiele die viel CPU fressen lass es über nvenc laufen und umgekeht natürlich auch. Zum anderen bei nem 11k Upload würde ich nich mit 6000 kb streamen bring nix da du eh nur 720p raus bekommst. Für gute 720p bei 60fps reichen 3500-4500. Dann wäre es mal Hilfreich wenn du deine Pc Specs reinhaust so kann man ungefähr beurteilen was mann verbessern könnte. Kann auch sein das du mit dem Anbieter probleme hast und das Ingame gar nicht merkst.
  • Hi !

    Prozessor Intel Core i5-3300 CPU @ 3.00 GHz 3.00 GHz
    Arbeitsspeicher 8 GB DD3
    Windows 10 64-Bit
    NVidia Geforce GTX 960 4GB

    Alles nicht so doll, streame allerdings auch nur Warcraft 3 Reforged mit Classic Grafik also an sich nicht sehr anspruchsvoll.

    Habe immer auf Hardware NVENC (new) gestreamt, bitrate auf 3500 oder 4000 eingestellt, Keyframeintervall 2, Voreinstellung "Qualität" und Profile "Main". Da gab es die Discnonnects, schon regelmäßig jeden Stream den ich laufen hatte, das zur Häufigkeit.

    Video Settings sind Base Resolution 1920x1080 skaliert auf 1280x720. Downscale Filter Lanczos, FPS Type Common FPS Values und 60 FPS.


    Habe dann nochmal den Software x264 Encoder probiert, mit Bitrate 2500, Very Fast und auf Main. Da gab es keine Disconnects mehr des Streams !

    Jetzt ist mir aber aufgefallen, dass ich wenn ich den Stream laufen habe 1. die Qualli nicht sogut ist wie sie eig sein sollte den settings nach und 2. die Bitrate zwischen 800 und 1200 schwankt ?!
    Setzt sich die Bitrate selber runter weil iwas nicht ausreicht ? Am Upload kann es nicht liegen, der ist immer stabil.

    Danke und entschuldigung schonmal vorweg, hab von Hardware leider nicht sehr viel Ahnung.

    Grüße
  • Also das System ist wie du schon gesagt hast wirklich nicht so gut zum streamen. Die Cpu ist zu schwach grade bei den Settings. Aber versuch mal pber die Cpu zu streamen schaue aber das du immer nen Konstanten Upload hast. Stelle die Rate auf 3000 oder 3500. Es gibt bei Streamlabs Obs die Option das er die bitrate anpasst das würde ich dir aber in keinem Fall empfehlen. Das steht auf Erweitertert dann auf Netzwerk un da steht da was mit Dynamically change Bitrate. Da den Harken raus weil da durch nimmt obs nur das was auch benötigt wird ich persönlich nutze das nicht weil mir aufgefallen ist das die Quali dadurch leidet.
  • Hey, danke sehr schonmal !

    Mit dem droppen der Bitrate hat es sich erledigt, hatte den Haken bei Dynamically change Bitrate drin. Allerdings wird es ja seinen Grund haben das die Bitrate beim Dynamischen change auf sogar unter 1000 teilweise droppt. Kann das an der schwachen Hardware liegen ? Wie gesagt mein Upload liegt konstant bei 10-11k.

    Danke
  • Also glaub ich eher weniger. hab nen i 7 7700k und ne 1080 drin und hatte die gleichen Probleme mit der Quali. Je niedriger die Bitrate desto schlechter die Qualität. Und ja es wird deswegen an der Hardware liegen. Musst du Testen versuchs mal über die CpU und da auch mal über die Grafikkarte. Dann wirst du sehen welsches besser ist und bei der Grafikkarte stell besser auf das normale nvenc und nicht auf nvenc New.
  • pogige schrieb:

    Hey, danke sehr schonmal !

    Mit dem droppen der Bitrate hat es sich erledigt ... Wie gesagt mein Upload liegt konstant bei 10-11k.

    Danke
    Also läuft es jetzt? Grundsätzlich gilt: nur weil die Speedtests immer den Wert ausgegeben haben, heißt es nicht, dass der auch konstant erreicht wird. Drops können zwischendrin immer mal wieder passieren. Vor allem, wenn man WLAN nutzt oder bei Kabel-Internet.
    Würde an deiner Stelle mal die FPS auf 30 stellen. Vielleicht reicht das schon. So schnelles Gameplay hast du da ja nicht, dass unbedingt 60 fps erforderlich sind, oder? Kenne das Game nicht so gut.
  • Soweit ich weis ist die Einstellung für die Dynamische Bitrate noch in der Beta. Ich verstehe sowieso nicht wofür die da ist und was die machen soll. Was du machen kannst wenn du Internet Probleme haben solltet, kannst du versuchen bei deiner Bitrate statt CBR (Constant Bitrate) Auf VBR zustellen (Variable Bitrate)

    Ich weis, jeder hier würde dir raten, die Bitrate fest zu nutzen, aber bei der VBR ist es so, das sich die Bitrate bei keiner Bewegung im Bild auf einem Minimum Bewegt. Sobald dann bewegung ins Bild kommt, klettert sie auf den Maximal Wert, den du angegeben hast. Ich hab das ganze schonmal getestet, klappt eigentlich ganz gut.

    Mit deiner Hardware solltest du unbedingt via NVENC streamen. Wie schon gesagt wurde, ist deine CPU einfach zu lahm um Spiel und Stream zu bewältigen.

    Ich glaube auch, das deine Abbrüche durch die Einstellung kam "Dynamic Bitrate" Zumal auch da steht, wenn man die Maus drüber hält, das diese Option aktuell nur für RTMP verfügbar ist. Ich weis, jetzt wird gleich wieder gesagt "Twitch ist doch RTMP" das ist richtig, allerdings interpretiere ich das so, das die direkte Einstellung im OBS gemeint ist.

    Noch eine Frage: Hast du zufällig auch einen Haken bei "Netzwerkoptimierung aktivieren" drin?
  • xlTheCrow schrieb:

    Soweit ich weis ist die Einstellung für die Dynamische Bitrate noch in der Beta. Ich verstehe sowieso nicht wofür die da ist und was die machen soll.
    Im Grunde macht die sowas Ähnliches wie VBR. Der Vorteil ist, dass die Bitrate eigenständig reduziert wird, wenn die angepeilte Bitrate nicht erreicht werden kann, um Framedrops zu vermeiden. Dass das in er Praxis natürlich noch nicht so doll funktioniert, merken wir hier ja gerade. :D
    Mehr dazu hier: blog.streamlabs.com/how-to-use-dynamic-bitrate-5a7ea1bbb678

    Das kennt man ja von Streaming-Diensten wie Netflix. Am Anfang wird in SD gebuffert und nach und nach die Qualität auf HD oder UHD gestellt, sofern der Download es zulässt. Gerade bei instabilen Internetverbindungen ist das recht praktisch. Der Unterschied zu VBR ist, dass VBR die Bitrate dauerhaft abhängig vom Bild regelt, bei der dynamischen Bitrate wird immer der Maximalwert angepeilt und es kommt nur bei Verbindungsproblemen zu einer Reduzierung.
  • xlTheCrow schrieb:

    Soweit ich weis ist die Einstellung für die Dynamische Bitrate noch in der Beta. Ich verstehe sowieso nicht wofür die da ist und was die machen soll. Was du machen kannst wenn du Internet Probleme haben solltet, kannst du versuchen bei deiner Bitrate statt CBR (Constant Bitrate) Auf VBR zustellen (Variable Bitrate)

    Ich weis, jeder hier würde dir raten, die Bitrate fest zu nutzen, aber bei der VBR ist es so, das sich die Bitrate bei keiner Bewegung im Bild auf einem Minimum Bewegt. Sobald dann bewegung ins Bild kommt, klettert sie auf den Maximal Wert, den du angegeben hast. Ich hab das ganze schonmal getestet, klappt eigentlich ganz gut.

    Mit deiner Hardware solltest du unbedingt via NVENC streamen. Wie schon gesagt wurde, ist deine CPU einfach zu lahm um Spiel und Stream zu bewältigen.

    Ich glaube auch, das deine Abbrüche durch die Einstellung kam "Dynamic Bitrate" Zumal auch da steht, wenn man die Maus drüber hält, das diese Option aktuell nur für RTMP verfügbar ist. Ich weis, jetzt wird gleich wieder gesagt "Twitch ist doch RTMP" das ist richtig, allerdings interpretiere ich das so, das die direkte Einstellung im OBS gemeint ist.

    Noch eine Frage: Hast du zufällig auch einen Haken bei "Netzwerkoptimierung aktivieren" drin?
    Als das bedeutet einfach das die Bitrate angepasst wird das heißt du benötigst du für deinen Stream nur 2000 hast aber 6000 eingestellt, regelt er automatisch runter auf 2000. Allerdings ist mir dabei was aufgefallen und zwar das dass nicht schnell genug geht. Trotz gutem Pc.