Twitch Stream laggt trotz gutem PC und Internetleitung?!

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren



Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo zusammen,
    ich bin nun völlig fraglos.

    Ich habe mir neue Hardware gekauft um auf Twitch endlich laggfrei in guter Qualität zu streamen.

    Meine Hardware:
    Inten i7 9700k
    Geforce RTX 2070
    16GB DDR4 3200 Ram G.skill
    MSI Mainboard z390

    Internetleitung: 1&1 250k (40mbit upload)

    Ich streame über OBS Studio aber anscheinend stimmen meine Einstellungen nicht, obwohl ich im internet viel geschaut und probiert habe.
    Ich streame mit 5000kbps, CBR, x264 kodierer (nvenc H.264 new habe ich auch schon ausprobiert), 720p60fps skalierung

    Spiel lief heute Mittag noch, nun komme ich von der Arbeit und ingame sind leichter mikroruckler konstant die ganze zeit und im stream sind ständig kurze freeze und laggs. nichts läuft flüssig.
    Woran kann es liegen? Hätte einer bessere OBS Studio Einstellungen für mich?
    Bin verzweifelt.

    Liebe grüße
  • Mit der Leitung kannst du das ruhig etwas hochstellen, um etwas Buffer zu haben. Der "richtige" Codec hängt vom Spiel ab. Noch wichtiger erscheint mir bei der Beschreibung aber eine "saubere" Leitung.
    Wenn du mehrmals über den Tag verteilt den Ping misst, wie ist der? Hast du auch Mikrolags, wenn du off-stream spielst?
  • das sind meine momentanen einstellungen. Mehrmals nun getestet und es ruckelt und ruckelt als zuschauer bzw für die zuschauer. habe es mit black ops 4 und pubg getestet. grafik in beiden spielen auf mittel.

    WICHTIG!!:
    wenn ich OBS offen habe, nicht mal auf stream starten drücke, habe ich sobald ich z,B. COD Black ops 4 starte 100% GPU auslastung. wenn obs geschlossen ist, ist die auslastung im spiel bei unter 10%.
    CPU Auslastung liegt bei Black ops 4 auf 100% konstant auch ohne obs offen
    Bilder
    • stream2.jpg

      55,5 kB, 985×777, 47 mal angesehen
    • stream3.jpg

      121,24 kB, 1.009×785, 43 mal angesehen
    • stream4.jpg

      77,69 kB, 781×701, 44 mal angesehen
    • stream5.jpg

      87,1 kB, 997×777, 45 mal angesehen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von fale90 ()

  • Kannst du bitte auch noch einen Screenshot von den Erweiterten Einstellungen posten?

    Das hört sich an, als wenn sich OBS mehrfach startet. Das Problem hatte ich auch mal, das ich mehere Instanzen von OBS offen hatte, obwohl ich nur einmal geklickt hatte. Ich kann dir allerdings nicht mehr sagen, wie ich das behoben bekommen habe...
  • Wie schon xlTheCrow sagte das kann sein das mehrere Instanzen offen sind die nicht offen sein sollen von den Einstellungen sehe ich jetzt nichts Falsches leider kenne ich mich mit dem NVENC gar nicht aus aber sieht meiner Meinung nach richtig aus, wenn du OBS startest schau mal wie oft es angezeigt wird
  • Hier nochmal ein bild der erweiterten einstellungen. Ich habe nun mal versucht über die cpu zu streamen. Läuft aufjedenfall flüssiger, auslastung der CPU ist aber trotzdem bei 100%. Temperaturen alle in ordnung und stabil (von gpu und cpu). Nun ist die qualität schlechter dadurch im stream. jetzt probiere ich wieder ein bisschen mit den einstellungen rum.

    Mich wundert einfach nur, das die 2070 es nicht schafft flüssiges bild zu streamen auf twitch oder auch youtube. Ich habe sogar die skalierte auflösung auf 480p60fps, auf 720p30fps und 480p30fps runtergestellt einfach um mal zu schauen wie flüssig der stream läuft. Es laggt genauso im stream für die zuschauer wie wenn ich 900p60 streame. Dies kann eigentlich überhaupt nicht sein. Kein plan was hier nicht rund läuft. Hab mir die 2070 extra geholt weil ich überall gelesen habe das die locker ausreicht zum streamen auf twitch. Kommt jetzt bitte nicht mit "hättest dir eine 2080 ti kaufen sollen" :D
    Bilder
    • stream 7.jpg

      180,26 kB, 1.457×1.009, 41 mal angesehen
  • Habs nach namen sortiert. das sind wirklich die einzigen prozesse von OBS. momentan ist obs offen aber kein spiel, nichts. CPU auslastung 30/31%, GPU 25%, RAM 30%. Streame zurzeit auch nur über CPU und nicht über die GPU. über gpu kann ich komplett knicken, da laggt es wie hundescheiße als zuschauer. CPU einstellungen sind von der bitrate und auflösung wie bei GPU, preset auf veryfast. sobald ich faster auswähle läuft es wieder unflüssig.
    Kann es evtl auch an zu wenig leistung am netzteil liegen? eigentlich läuft aber alles rund, auch wenn ich den pc 15 stunden laufen lasse habe ich keine probleme. netzteil habe ich 500w von bequiet was eigentlich auch ausreicht.

    hier nochmal die OBS einstellungen wenn ich über cpu streame

    und ein bild vom taskmanager
    Bilder
    • cpu1.jpg

      89,02 kB, 981×789, 32 mal angesehen
    • cpu2.jpg

      61,37 kB, 1.009×785, 33 mal angesehen
    • task.jpg

      171,38 kB, 1.029×601, 37 mal angesehen
  • Moin,

    als stiller Mitleser, der gerade erst dabei ist sich sein Streaming-Setup aufzubauen, wollte ich mich hier eigentlich erst später anmelden.
    Eine Idee, zu deinem Problem hätte ich aber jetzt schon. ;)

    Zur CPU Auslastung:

    Kann es sein, dass während du den Screenshot vom Task Manager gemacht hast zwar kein Spiel lief, OBS aber live war? Nur so kann ich mir die Netzwerkauslastung von 5,1 Mbit/s erklären. Dann wäre deine CPU Auslastung soweit normal, würde ich sagen.

    Zum encoden über die GPU:

    Aktuell soll es wohl Probleme bei der Ressourcenverwaltung zwischen Windows 10 und OBS geben, wenn über die GPU gestreamt wird und die GPU stark ausgelastet ist. Da die meisten Spiele von der Grafikkarte limitiert werden, ist das fast immer der Fall. Probiere doch mal die Grafikeinstellungen soweit herunter zu setzen, dass du im CPU Limit landest, deine GPU Auslastung ingame also (deutlich) unter 97% sinkt. Alternativ kannst du auch die FPS im Spiel limitieren. Um ingame deine GPU Auslastung zu sehen, würde sich als Tool der MSI Afterburner anbieten. Wie hast du denn bis jetzt die Auslastungen ausgelesen, nur über den Task Manager?
    Zuerst kannst du aber mal den Gamemode in Windows einschalten, der soll, in 1080p (deine Auflösung, nicht die vom Stream) das Problem angeblich in machen fällen lösen, weil sich OBS dann die benötigte Leistung von der GPU reservieren kann, auch wenn diese voll ausgelastet ist.

    Außerdem gibt es gerade Probleme mit der Preview in OBS, die kannst du testweise auch mal deaktivieren.

    Edit: Eher unwahrscheinlich, da es über die CPU ja mehr oder weniger geht, aber zuallerallererst könnest du mal alle außer einen Monitor abstecken. Gibt wohl gerade ein Problem wenn man Monitore mit verschiedenen Hz-Raten kombiniert.

    Gruß
    .Rock

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dot-Rock ()

  • Animierte overlays habe ich nicht. alles statisch :D und auch nur für die webcam ein.

    Ja, während der aufnahme war ich live, aber trotzdem ist es zuviel. Du bist glaube der erste der schreibt, das ich den game mode aktivieren soll. Überall anders steht, das man diesen deaktivieren soll :D
  • Mein Tipp mit dem Game Mode bezieht sich auf folgenden Tweet von OBS: twitter.com/obsproject/status/1113133048957153287?s=21
    Bis zu dem Update hat tatsächlich jeder empfohlen den Game Mode zu deaktivieren. Kostet ja nichts, es jetzt mal zu testen.

    Hast du denn meine anderen Vorschläge schon getestet? Testweise nur einen Monitor verwenden, die Preview in OBS deaktivieren (könnte der Grund für deine ingame Probleme sein) und deine Game-FPS soweit limitieren, dass deine GPU selbst während dem streamen mit NVENC nicht ausgelastet ist (könnte der Grund für deine Stream Probleme sein).

    Außerdem ist mir in deinem Task Manager aufgefallen, dass du Nvidia Share laufen hast. Das würde ich auch deaktivieren.

    Gruß
    .Rock