Probleme beim Streamen mit OBS Studio

  • Moin,

    ich habe starke Probleme beim Streamen FPS weit unter 10 über 30ms Renderverzögerung und Codierungsverzögerung über 60 Prozent. Der PC ist grade mal ein paar wochen Alt meine Eintellungen in OBS sind

    Encoder: Nvidia NVENC H.264 (new)

    CBR

    6000 Kbps

    Keyframeinterval in sec = 0

    Voreinstellungen : Qualität

    Profil : high

    Psycho Visual Tuning : AN

    GPU = 0

    Max. B-Frame = 2

    VIDEO:

    Basis 1920x1080

    Skalierte Ausgabeauflösung 1600x900

    Skalierungsfilter : Bicubic 16 Stichproben

    Üblicher FPS-Werte 60

    Sound:

    Wave Link

    Alles Deaktiviert bis auf Mic Wave Link Stream (2- Elgato Wave 3)


    Mein PC

    PC : AMD 4700S 8-Core, 3600 MHz, 8 Kern(e),

    16 GB Arbeitsspeicher,

    NVIDIA GeForce RTX 3060 12 GB, aktuelle Treiber

    1 TB Festplatte SSD,

    StreamDeck XL, mit Software

    StreamDeck, mit Software

    2 x Key Light (nicht am PC aber durch Software verbunden), mit Software

    Elgato Wave 3, mit Software

    3 Monitore Verbunden von HDMI auf Displayport, Oculus Rift (hab ich auch schon abgemacht aber lief auch nicht besser),

    USB 3.0 Verteiler (wo Maus, Sensoren und die Decks angeschlossen sind).

    Logitech Streamcam, mit Software

    Internet 1000 Leitung mit 50ger Upload

    3 Monitore HDMI auf Displayport.

    Oculus Rift VR Headset aucg bei abschluß der Rift keiner verbeserung

    und ich nutze text to Speach im internet über Firefox (Mein Internetbrowser)


    Die Nutzung aller Software kann ich hier leider nicht reinschreiben sonst heißt es wieder Werbung


    Windows Game Mode ist Deaktiviert und dennoch funktioniert es irgendwie nicht.

    Ich weiß einfach nicht mehr weiter. Der PC ist komplett neu. Kann mir bitte einer Helfen wie kriege ich es wieder zum laufen ?

    ?

  • Ich hab rausgefunden woran es liegt an der Streaming Webcam von Logitech. Ich hab es schon mit der Logitech c920 und dem Vorgänger von Logitech versucht aber beide hauen mir die FPS ,Ränder Verzögerung und die Codierungsverzögerung so dermaßen runter (in Roten Bereich). Treiber habe ich alle Installiert aber hat leider nichts genützt. Kann mir wer eine günstige alternative empfehlen, die die Sachen nicht droppen lässt und nicht von Logitech sind?

  • Zum einen...Keyframeintervall nicht auf Auto stehen lassen. Das verursacht nur Probleme und kann ebenfalls zu Verzögerungen im Render und Codiervorgang führen. Laut Twitch dies auf 2 stellen.


    zum Zweiten... Treiber von den Kameras brauchst du in der Regel nicht. Auch die Software der Kameras sind unnötig. Ich habe auch Logitech kameras. Einfach anschließen, Treiber werden automatisch von Windows installiert und dann kannst du sie in OBS einbinden.

    Game Mode von Windows sollte mittlerweile aktiv sein, da Windows selber dafür gesorgt hat, das es da keine Probleme mehr gibt.

    Ich hatte auch mal Text to Speech vor in meinem Stream, leider hat es meinen PC vollkommen einfrieren lassen und die FPS sind massiv runter gegangen. Vielleicht auch hier ansetzen.

  • Ok hab es versucht den Chromakey auszumachen bleibt leider bei den Roten zahlen. Wegen den Dock die Sachen sind da nicht nur die Standard und Browserquelle hinzufügen (Manuel) . wegen der "die Auflösung der Kamera reduziert" in OBS reduziert also z.B. getestet von 1920x1080 bis auf 360x640 und selbst von 60 ntsc auf 50 getestet auch da leider wieder extrem Roten zahlen. Aber es kann doch nicht sein das die Kamera vorher an einem Intel I7 4400 angeschlossen war und es ging und das die StreamingCam und die c920 AMD 4700S dann nicht unterstützt wird ! Kann es echt daran liegen das Logitech nur und ausschließlich Intel unterstützt und nicht AMD ?

  • Hab alles mitgelesen und gerade einen Gedankenblitz.


    Check mal das Format. Wenn du beim der Cam beispielsweise RGB zur Auswahl hast, solltest du das nicht wählen. Auch YUY2 wird damit nicht laufen. Weiß grad nicht aus dem Kopf, welche da unterstützt werden. Mit NV12 fährst du da in der Regel am besten.


    Falls das nicht hilft, weiß ich auch nicht mehr weiter. Mit AMD oder Intel sollte das aber nichts zu tun haben.

  • ok aber trotzdem danke. Also laut der Logdatei, soll es probleme mit der Spieleaufnahme geben weil ich mehre Spiele in je einer eigenen Spielaufnahme in einer Szene habe/hatte und das zweite war wegen der Webcam weil ich die wohl auf 1080p gehabt haben soll, darf man wohl nur auf writ unter 720 dann haben und nicht direckt in der Hauptszene sondern über Verschachtelung wenn ich das richtig verstanden habe. Und man soll wenn man mehrere Spiele Streamt das über eine einzige Spieleaufnahme mit Hotkeys machen laut OBS Discord, weis nur nicht wie das genau geht. Wenn du oder wer anders wis wie das geht bitte gerne antworten. beim Test mit 1080p im Stream lief es dann teilweise ganz ok es gab zwar wieder bis ins Orange fehlende Drops hab dann die Kamera auf glaube 360 oder 460p gestellt lief dann besser aber wohl wegen der 3 Spieleaufnahmen statt einer gabs wieder Fail Drops. Aber trotzdem Danke für deine mühen.

  • Also ich hab das damals, als ich noch Single PC Setup hatte, auch so gemacht, das ich für jedes Game eine andere Szene hatte, aber vielleicht haben die etwas verändert und nun gibt es Probleme.
    Also entweder du versuchst es über die Spielaufnahme, dann aber über "Beliebige Vollbilsanwendung erfassen" dann sucht OBS eben nach einem Vollbildspiel, unabhängig der .exe

    Oder du versuchst es über Bildschirmaufnahme. Dann streamst du zwar deinen kompletten Bildschirm, also auch deinen Desktop, aber das funktionierte in der Vergangenheit immer am Besten. Aber man muss eben aufpassen, was man auf dem Monitor zeigt.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!