Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren



Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hi,
    ich habe ein Problem mit meinem Stream. Der Stream und Aufnahme laggen ab und zu obwohl ich ingame keinerlei FPS Probleme habe und CPU bei 80% und GPU bei 60% Auslastung liegt. Habe das problem bei Assassins Creed Odysse und das neue COD MW. Habe FPS Lock auf 30 an um Auslastung zu verringern (hat aber nicht viel geholfen).
    Habe zusätzlich schon versucht die Prioritäten zu verändern, Windows DVR zu deaktivieren und StreamlabsOBS als Admin zu starten. Trotz alledem kommen immernoch lags bei neueren Spielen auf.
    Ich benutze Streamlabs OBS mit folgenden Einstellungen:

    Hardware NVENC (new)
    CBR
    Bitrate: 5000
    Keyframe: 2
    Max. Qualität
    Profile: High
    Checked Psycho Visual Tuning
    Max. B-Frames: 2

    Meine Specs sind:
    Nvidia RTX 2080 ti
    Intel Core i7 8700k
    32 gb ram
    Internetupload: 10 Mbt/s
    Auflösung: 3440x1440
    Stream skalliert auf: 1720x720

    Hoffe irgendwer kann mir helfen …
  • Hast du den Game Mode bei Windows auch ausgeschaltet?

    10 mbps bei 5 mbps als Setting, ist recht knapp, würde ich meinen. Versuch mal, 3000 Kbps einzustellen und versuche es damit erneut, falls das mit dem Game Mode nix bringt.

    Nutzt du mehrere Monitore? ich meine, dass wir das Problem hier schon mal hatten mit mehreren Monitoren, vor allem mit unterschiedlichen Auflösungen auf unterschiedlichen Geräten.
  • also 5000 bei 10 mbit upload sind schon in ordnung...ich hab auch nicht anders gestreamt. Allerdings würde mich interessieren, warum die Auflösung auf 1720x720 steht und nicht auf 1280x720. Das verzehrt doch den Streamoutput unnötig und es sieht nicht schön aus...meiner Meinung nach.
    Du kannst auch versuchen das Psycho Visual Tuning auszumachen. Kann mir vorstellen, das dies gut was an Leistung zieht. Dann noch mit was für einen Takt läuft der RAM? Und wie viel Takt hat der i7?
    Kannst auch mal versuchen auf Qualität zustellen statt auf Max Qualität.
  • Moin!

    @xlTheCrow die Auflösung von 1720x720 macht schon Sinn, er spielt ja auch in 3440x1440.

    Könnte natürlich an deinem Internet liegen. Je nach dem, wie stabil deine Leitung ist, kann auch eine 5000er Bitrate dein Upload an die Grenzen bringen. Bist du über Lan oder W-Lan verbunden? Bist du der einzige in deinem Netzwerk?
    Bei OBS Studio (Streamlabs hat das glaube ich nicht) hast du die Möglichkeit, dir bei Streamen detailliertere Statistiken anzuzeigen (Ansicht -> Statistiken), die sollten etwas mehr Klarheit schaffen.

    Vielmehr vermute ich aber, dass der Stream laggt, weil du eben doch FPS Probleme hast, die dir, vielleicht dank G-Sync nicht auffallen. Bei 02:32 deines letzten Streams sieht man, dass du in in Odysse extreme Frame-Drops hast. Ich kann mir vorstellen, dass OBS daraus einfach kein flüssiges Bild erzeugen kann. Auffällig ist, dass sowohl CPU-/ als auch GPU-Frametimes stark schwanken. Bei der CPU könnte ich mir das noch erklären, da Odysse sehr CPU-lastig ist und 80% Auslastung schon im Limit sein können. 6 Kerne sind halt auch nicht mehr so viel. Die GPU-Frametimes finde ich aber ungewöhnlich. Wäre interessant, mal deine kompletten Specs zu sehen, vor allem dein Netzteil. Außerdem wäre es Hilfreich, wenn du dir mal mit MSI Afterburner Ingame deine GPU/CPU Auslastung und FPS anzeigen lassen könntest, und dabei vielleicht einfach mal ein paar Minuten streamst, damit ich mir das Video später angucken kann.



    Was mir noch aufgefallen ist: Du scheinst sehr viele Programme im Hintergrund laufen zu haben, z. B. auch Avira Antivir, was immer gerne Probleme macht und seit Windows 10 eigentlich eh überfällig bis kontraproduktiv ist, da der Windows Defender mittlerweile so gut ist, dass man keine anderen Anti-Viren Programme mehr bracht.

    Gruß
    .Rock

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dot-Rock ()

  • Dot-Rock schrieb:

    Moin!

    @xlTheCrow die Auflösung von 1720x720 macht schon Sinn, er spielt ja auch in 3440x1440.

    Könnte natürlich an deinem Internet liegen. Je nach dem, wie stabil deine Leitung ist, kann auch eine 5000er Bitrate dein Upload an die Grenzen bringen. Bist du über Lan oder W-Lan verbunden? Bist du der einzige in deinem Netzwerk?
    Bei OBS Studio (Streamlabs hat das glaube ich nicht) hast du die Möglichkeit, dir bei Streamen detailliertere Statistiken anzuzeigen (Ansicht -> Statistiken), die sollten etwas mehr Klarheit schaffen.

    Vielmehr vermute ich aber, dass der Stream laggt, weil du eben doch FPS Probleme hast, die dir, vielleicht dank G-Sync nicht auffallen. Bei 02:32 deines letzten Streams sieht man, dass du in in Odysse extreme Frame-Drops hast. Ich kann mir vorstellen, dass OBS daraus einfach kein flüssiges Bild erzeugen kann. Auffällig ist, dass sowohl CPU-/ als auch GPU-Frametimes stark schwanken. Bei der CPU könnte ich mir das noch erklären, da Odysse sehr CPU-lastig ist und 80% Auslastung schon im Limit sein können. 6 Kerne sind halt auch nicht mehr so viel. Die GPU-Frametimes finde ich aber ungewöhnlich. Wäre interessant, mal deine kompletten Specs zu sehen, vor allem dein Netzteil. Außerdem wäre es Hilfreich, wenn du dir mal mit MSI Afterburner Ingame deine GPU/CPU Auslastung und FPS anzeigen lassen könntest, und dabei vielleicht einfach mal ein paar Minuten streamst, damit ich mir das Video später angucken kann.



    Was mir noch aufgefallen ist: Du scheinst sehr viele Programme im Hintergrund laufen zu haben, z. B. auch Avira Antivir, was immer gerne Probleme macht und seit Windows 10 eigentlich eh überfällig bis kontraproduktiv ist, da der Windows Defender mittlerweile so gut ist, dass man keine anderen Anti-Viren Programme mehr bracht.

    Gruß
    .Rock
    Hi,

    danke schonmal für die schnellen Antworten!
    Ich hab das ganze jetzt nochmal alles mit Aufnahmen durchgetestet und hatte das selbe Ergebnis. Also das Internet denke ich kann ich ausschließen.

    Die starken Fps Drops im stream kamen davon das ich dort den Software Encoder ausprobiert habe und die FPS noch nicht gelockt habe.

    Das mit Avira werd auf jeden Fall noch Testen sowie einen stream mit Daten hochladen!

    RAM sind DDR4-3733.
    Und i7 läuft mit 4,2 ghz.

    Und Auflösung kann ich nicht ändern weil ich einen ultrawide Screen habe und das durchgehend dann verzerrt wäre für mich wenn ich das bei mir auf 1080p stellen würde.

    Habe auch schon das Windows Game deaktiviert und hat bisschen geholfen aber auch nicht viel.

    Bei nicht so anfordernden spielen läuft der stream echt gut. Zum Beispiel bei Arma oder csgo.

    Bin mit meinem Latein echt am Ende ...

    Danke nochmal an alle schnellen und viele Antworten!
  • Naja, du musst die Auflösung ja nicht für dich ändern, aber du kannst die Ausgabe für den Stream ändern, wobei wenn du das machen würdest, wäre die ausgabe auch wieder hässlich...egal was man machen würde, es würde nicht gut aussehen..

    3700 mhz sind schon eine ansage...

    Hast du denn die Sachen getestet, die ich auch schon geschrieben hatte?

    also...ich hatte mal einen Kumpel, der hatte mit dem Assassins Creed Teil auch so seine Probleme. Das Spiel ist halt auch fordernd für die Hardware.
    Ich will halt auch nicht der Spielverderber sein, aber entweder Qualität im Spiel runter stellen und schauen obs was bringt oder auflösung vom Spiel ändern...beim Streamen muss man kompromisse eingehen. Man will zwar geile Qualität haben, aber auch streamen. Und um beides zu bewerkstelligen, braucht man eine extrem gute Maschine
  • xlTheCrow schrieb:

    Naja, du musst die Auflösung ja nicht für dich ändern, aber du kannst die Ausgabe für den Stream ändern, wobei wenn du das machen würdest, wäre die ausgabe auch wieder hässlich...egal was man machen würde, es würde nicht gut aussehen..

    3700 mhz sind schon eine ansage...

    Hast du denn die Sachen getestet, die ich auch schon geschrieben hatte?

    also...ich hatte mal einen Kumpel, der hatte mit dem Assassins Creed Teil auch so seine Probleme. Das Spiel ist halt auch fordernd für die Hardware.
    Ich will halt auch nicht der Spielverderber sein, aber entweder Qualität im Spiel runter stellen und schauen obs was bringt oder auflösung vom Spiel ändern...beim Streamen muss man kompromisse eingehen. Man will zwar geile Qualität haben, aber auch streamen. Und um beides zu bewerkstelligen, braucht man eine extrem gute Maschine
    Das wäre dann ja wieder verzerrt bzw fischauge :o

    Mein Netzteil ist ein 800 Watt Netzteil von bequiet.

    den Psycho Visual Probier ich dieses Wochenende noch aus, bin ich noch nicht dazu gekommen ...

    Qualität runter stellen hab ich auch probiert bringt nur wenig bis gar nichts ... ich versteh es halt auch nicht weil keines meiner Hardware ausgelastet ist ... ich hatte jetzt die Fps auf 30 gelockt und das hat noch weniger Auslastung gebracht aber immernoch Probleme mit Laggs...
    Streamlabs OBS zeigt mir nur an das ich 28% Ausgelassene Frames hab aber woran das liegt krieg ich einfach nicht raus..
    Meinst du die RAM sind das Problem? Weil auch da hab ich kaum Auslastung ...

    danke für die Hilfe und Antwort nochmal!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Dennis Bauer ()

  • Ich würde dir, wie schon gesagt, auch echt OBS Studio empfehlen. Damit könntest du dann auch etwas genauer den Grund für die ausgelassenen Frames sehen.

    Trotzdem vermute ich das Problem immer noch nicht direkt bei OBS, sondern bei der allgemeinen Performance deines Systems.
    Andere mit einem 8700K, 32GB Ram und einer 2080 Ti können die Spiele ohne Probleme streamen.

    Es wäre also wirklich hilfreich, wenn du mal einen Test-Stream mit dem Overlay von MSI Afterburner (siehe Video von oben) machen wüdest. Dabei unbedingt über den NVENC (new) Encoder streamen und im Tab „Überwachung“ in den Einstellungen vom Afterburner am besten einfach jeden Parameter anzeigen lassen. FPS und Frametimes bitte als Text + Graph.

    Was du sonst noch mal probieren kannst:
    Die Preview in OBS deaktivieren und testweise nur einen Monitor verwenden.
  • Dot-Rock schrieb:

    Ich würde dir, wie schon gesagt, auch echt OBS Studio empfehlen. Damit könntest du dann auch etwas genauer den Grund für die ausgelassenen Frames sehen.

    Trotzdem vermute ich das Problem immer noch nicht direkt bei OBS, sondern bei der allgemeinen Performance deines Systems.
    Andere mit einem 8700K, 32GB Ram und einer 2080 Ti können die Spiele ohne Probleme streamen.

    Es wäre also wirklich hilfreich, wenn du mal einen Test-Stream mit dem Overlay von MSI Afterburner (siehe Video von oben) machen wüdest. Dabei unbedingt über den NVENC (new) Encoder streamen und im Tab „Überwachung“ in den Einstellungen vom Afterburner am besten einfach jeden Parameter anzeigen lassen. FPS und Frametimes bitte als Text + Graph.

    Was du sonst noch mal probieren kannst:
    Die Preview in OBS deaktivieren und testweise nur einen Monitor verwenden.
    So habs jetzt gefunden was das Problem war...
    Ist aber wiederum jetzt wieder ein neues :D

    Das Problem war der 2t Bildschirm der auf 1920x1080 60Hz lief.
    Wenn dieser Ausgesteckt ist funktioniert der Stream ohne Probleme und aufnahmen laufen flüssig.

    Das neue Problem ist: Wie kann ich das ausstecken des Bildschirms umgehen oder bzw gibt es einen Trick das zu fixen ohne den Bildschirm ab zu stecken?

    Da ich den 2t Bildschirm brauche, zwecks Dashboard und Chat wäre dieser schon von Vorteil... Kann mir jemand bei dem neuen Problem helfen ??
  • Das Problem gibt es schon länger und ist recht verbreitet. Einen Fix ohne Kompromisse kenne ich aber leider nicht.
    Der Grund sind aber die unterschiedlichen Hz-Werte der Monitore.
    Bei mir kannte ich es bis jetzt nur, dass ich im Spiel Mikroruckler habe, der Stream aber flüssig läuft.

    Bevor man sich jetzt aber einen neuen Monitor kauft, kann man das Problem umgehen, indem man die Preview in OBS deaktiviert und sicherstellt, dass auch keine anderen großartigen Bewegungen auf dem zweiten Monitor stattfinden.
    Du kannst das ganze mal testen indem du auf deinem 144hz Monitor die Seite testufo.com öffnest und auf dem zweiten Monitor dann OBS mit der Preview oder ein YouTube Video.