4k Streaming lagg Problem

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren



Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Moin Moin,


    bin neu hier im Forum hab schon nach meinem Problem gesucht aber das scheint speziell zu sein....
    Ich versuche grade mit 2 Rechnern mit den NDI Plugin in OBS zu streamen kurze Infos zu meinen PCs


    Gaming PC:
    Intel i7 6700k


    32GB RAM


    nur SSDs drin verbaut


    GeForce 2080 Watercooling


    Win10


    Monitor Asus ROG Swift PG348Q 34Zoll pixel 3440x1440


    Streaming PC
    Intel i7 3930k


    48GB RAM


    HDD


    GeForce 1080
    Win10


    Monitor 27 Zoll, pixel 1920x1080


    Beide sind mit nem Cat7 Kabel an nen Router (fritzbox) angeschlossen an eine 100mbit Leitung...


    Spiele Division z.Z es läuft flüssig auf den "4k" auf meinem Gaming PC, der Streaming PC bekommt durch das NDI Plugin übers OBS den imput vom Game und zusätzlich ist noch meine WebCam an den Streaming PC angeschlossen.


    Jetzt kommt das seltsame, sobald ich den stream anschmeiße ist noch alles ok, nach paar min kommen aber krasse laggs und zwar nicht der gesamte stream, sondern nur das Game Laggt, meine WebCam zeigt mich an und mein Bild wird flüssig angezeigt.
    Beim Gaming PC läuft OBS streamt aber nicht, sondern soll einfach an sein mit dem Game, was ich über NDI Plugin an den Streaming PC weiter leite, Gaming PC hat die einstellung mit 3440x1440 auflösung auf 30FPS mein Monitor spuckt mir aber 100FPS aus (meistens kommen etwas mit 85-95 an)


    Eigentlich sollte es egal sein, weil der Streaming PC das Bild eh bekommt und ich dort einfach die Skalierung des Fensters vom Gaming PC an das Format angepasst habe. (also die 1920x1080 weil Twitch ja nicht mehr nimmt) und beim Streaming PC ist die OBS Ausgabe auf erweitert, Encoder Hardware NVENC, CBR, Bitrate 6000, keyframes 0, Max Performance, Profil High. (auch schon andere einstellung ohne erfolg getestet)


    Was mach ich falsch, dass es diese krassen laggs gibt... es ist schon unnormal, würde es die ganze zeit laggen dann wäre hier ja so einiges falsch, aber es ist manchmal so "ok" ab und zu framedrops wenn ich mich zb schnell mit der Kamera im Game bewege dann seh ich das beim Streaming PC das ab und zu ma n bild fehlt...
    bin ich beispielsweise in ner Instanz länger am Spielen kommt random einfach so diese mega laggs im Stream, bei meinem Gaming PC ist alles super... nur meine zuschauen bekommen Diashow...
    es ist schon so schlimm das ich gesehen hatte wie ich mit meinem Charakter im Game down ging von nem Gegner und paar sekund später belebt wurde vom Teammitglied, das wiederbeleben fehlte ganz im Stream... war also tot und wieder am leben im nächsten Bild nach den Laggs.


    Gibt es eine andere Methode ohne das NDI Plugin? sollte ich Crossover kabel mal versuchen, um eine direkte Verbindung vom Rechner zum Rechner zu haben?
    Ich versuche noch weitere Einstellungen, oder vll sogar mal ohne Streaming PC ob das flüssig läuft, ziel beim zwei PC Setup war aber eigentlich das mein Gaming PC gar nicht vom Streamen betroffen wird :(


    Bitte um Hilfe, vielleicht hat hier schon jemand mit so einem Setup Erfahrung...
  • Wenn ich es richtig verstanden habe schickst du das Bild vom Gaming Pc in 3440x1440 zum Stream Pc?

    Beide Pc's sind via Gigabit angeschlossen?

    Kann mir gut vorstellen das die Verbindung mit der Auflösung überlastet ist.
    Schick es doch vom Gaming Pc gleich in 1080/60 weiter?
  • Hi kopfzaub9r, die auflösung wird schon vom Gaming PC runter skalliert



    Ich dachte anfangs das liegt an der Verbindung beider PCs, deswegen hab ich die kabel ausgewechselt auf Cat7.
    Nächster schritt wäre die beiden über n Crossover zu verbinden, aber vll gibs ne andere lösung.


    So nun hab ich sogar noch die Basis Auflösung auf 1920x1080 am Gaming PC gemacht und es ist immernoch so das es mal für paar sek flüssig rüber kommt und manchmal so ne übertriebenen laggs kommen, als ob er irgendwo Datenstau hätte... steh zb in Division 2 in der gegend rum, alles ok... bewege ich mich alles gut, die maus etwas schneller bewegt am Gaming PC im spiel alles super aber der Streaming Rechner bekommt aufeinmal ruckler bei den schnelle bewegungen, WTF? Als ob er da was rechnen müsste... -.-° ich komm echt nicht weiter.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von VenoomArt ()

  • Ein Zauberwort...Vsync ;) ich hab das auch ma gehabt, sobald ich mich bewegt habe ingame gab es so harte Ruckler, das es einer Diashow gleichkam. Sobald ich aber Vsync an hatte, war das vorbei. Ich weis, das sollte so nicht sein und viele können auch mit über 100 fps spielen und 60 fps streamen, aber in manchen fällen ist es so, das man vsync anmachen muss, damit es flüssig rüber kommt...
  • Danke für dein Vorschlag, aber VSync ist im game an.. und wie gesagt es laggt nur der Streaming Rechner,
    das sieht ja auch noch lustig aus, meine Kamera mit Greenscreen ist an
    den Streaming Rechner angeschlossen und das Bild ist super keine laggs, alles gut und im Hintergrund sieht man Division mal flüssig mal am laggen...


    Wurde da ja erst aufmerksam als mir gesagt wurde "digga den stream laggt" ... und bei mir war alles super, hmm schaute auf den Streaming Rechner und Tatsache voll die laggs drin.
  • Wie siehts mit deinem Arbeitsspeicher aus? Nein, nicht von der Menge sondern von der Beanspruchung her? Wie ausgelastet ist/sind deine RAMs? Hast seit neuestem irgendein Progamm im Hintergrund laufen, welches vorher nicht genutzt wurde? (wo alles gut war)

    Evtl. ist auch die GPU "überlastet" einer deiner PCs?

    Probier mal eins nach dem anderen auszuschließen, sprich, einmal ohne Cam, einmal ohne GreenScreen usw. usw. evtl. auch mal versuchen mit MSI Afterburner oder ähnlichen die Leistung der GPU/s zu erhöhen und/oder CPU bzw. RAM
  • @ High PringleZZ
    also zum thema der PCs CPU und Ram sind nicht ausgelastet,.. Ich hab auch nix anderes nebenbei offen.. selbst mein Firefox mit 100 Tabs mach ich davor dicht.
    Ich check das einfach nicht, beide nicht ganz ausgelastet und trotzdem am stottern wie ein kranker Mensch.



    @ kopfzaub9r
    ich hab auch kleinere auflösung getestet, zb hab ich auf den Gaming PC direkt die auflösung auf 1920 von 3840 runter gemacht... laggt trotzdem rum was komisch ist.

    @ dungi
    Ja ich bin ja nicht einfach so auf das Plugin gekommen, habe natürlich einige youtube videos geschaut das ich darauf gekommen bin,.. und auch die einstellung so laut der User die auch ne 4k auflösung streamen wollen mit dual pc setup...

    Ich komme leider immernoch nicht zu einem guten ergebnis, habe jetzt sogar nur über mein Gaming PC gestreamt und selbst mit einer 1920 auflösung mit 60FPS und auf Encoder hardware NVENC läuft hier nix flüssig... ich versteh da nicht was ich sovieles falsch mache bei den Setup... da ist ne 1000€ karte drin und dann sowas xD
  • Die Hardware kann noch so teuer sein, wenn die Komponenten nicht auf einander abgestimmt wurden, bringt das alles nix.

    Alle Treiber sind aktuell? Keiner der Stecker sitzt locker in der Büchse? Die Hardware ist neuer, richtig? Somit können defekte ausgeschlossen werden? Vl. ist in diese Richtung das Problem, evtl. gibt oder hat ein Teil den Geist aufgegeben bzw. streikt..
  • also wenn hier irgendwas kaputt wäre, würde das ja beim "nicht streamen" auch laggen... alles steckt richitg, alles wird richitg erkannt.. keine hardware defekts... Kann alles auf 4k zocken, mit fast allem auf das höhste was geht in jeglicher einstellung und nix laggt... naja in The Division ab und zu n mini lagg, der kommt glaub ich eher vom Game selbst, weil 1 damals auch net perfekt war... witzig is halt wenn ich beide rechner an habe und OBS hier am Gaming PC nur an ist aber nicht streamt.. der Streaming PC ist auch an, OBS auch, bei beiden mit Plugin, der eine sendet der andere bekommt... bild sieht gut aus, nix laggt rum, alles top!
    Sobald ich stream online gehe ist anfangst noch ok... ab und zu hackt es nach... aber diese krassen laggst kommen dann nach paar min. und immer mehr, aber nicht am Gaming PC. nur im Stream und nur das Bild vom Spiel, (Face Cam ist angeschlossen direkt am Streaming PC und bringt gutes Bild)