Stream Verpixelt / Blurry bei Bewegung

Herzlich Willkommen auf StreamTalk.de, deiner Community rund um Twitch, Hitbox und Co.

Bei uns kannst Du deine Gedanken zu Twitch, Hitbox und Co. mit anderen teilen und Dich über interessante Themen rund ums Streaming austauschen, z.B. Chatbots, Donations, Sponsoring, Overlays, etc. Erhalte Hilfe und wertvolle Tipps für den Aufbau deines Streaming Channels. Außerdem kannst du deinen Stream in einem eigenen Bereich bei uns vorstellen oder nach Partnern für gemeinsame Projekte suchen.

Wir würden uns freuen, wenn du ein Teil dieser großartigen Community wirst: Jetzt registrieren



Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklärst du dich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo Community,

    ich bin neu hier und wende mich jetzt nach laaaaaaaaaaaangem testen hierher.

    Also, ich bin ein Streamer mit rund 450 Follower'n und Dual PC Setup (Elgato halt dann). Ich streame auf Twitch.

    Ich benutze OBS Studio Version 23.x - 810p60 und NVENC mit 6000kb/s Bitrate im CBR.

    Naja mein Problem? Der Stream wird extrem Verpixelt wenn ich mich bewege, Elgato(also Ingameaufnahme) + Webcam.
    Vor Tagen ging noch alles perfekt, nichts wurde verpixelt etc..

    Ich habe eine Szene zum Test erstellt in der nur die Elgato sich befindet + Webcam - Ich bewege mich im Stream und beides wird extrem Verpixelt, wenn ich aber dann die Elgato deaktiviere (ausblenden) wird die Kamera sofort gestochen scharf, Elgato wieder einblenden und Webcam wieder verpixelt.

    Ich habe schon alles probiert, wirklich alles.
    720p60 selbes Problem, auch mit 30FPS. x264 genau das selbe 60 sowie 30FPS.
    Es hat einfach nichts geklappt, ich habe sogar meinen Streaming PC komplett neu aufgesetzt!


    Das selbe Problem besteht auch wenn ich von meinem Gaming PC aus Streame! Das Bild wird Verpixelt wenn ich mich bewege obwohl der PC deutlich besser als der Streaming PC ist.



    Wie gesagt - 130mb download / 10-13mb upload
    Ich bin kein Anfänger und kenne mich damit relativ gut aus, aber nun ist mein latein am Ende. HILFE!

    Streaming PC:

    Intel Core i5 3570k
    GTX660
    16GB RAM DDR3


    GAMING PC:

    Intel Core i7 8700k
    GTX1070
    16GB RAM DDR4

    Hoffentlich kann mir jemand helfen.. :(
  • Gut, wenn du ja schon alles weißt, ist es schwer, dir zu helfen ...
    Ist es auch bei den VODs verpixelt? Hast du den Gaming Modus in Windows mal abgeschaltet? Treiber aktuell? Mal Treiber deinstalliert und Neuinstallation gemacht? Elgato mal an einer anderen Stelle angeschlossen? Da niemand weiß, welche Elgato, kann ich da nicht mehr zu sagen. Wenn’s ne 60S öder höher ist, USB3 bzw. PCi nehmen. Sonst halt USB2.
  • VOD‘s? Treiber sollten aktuell sein, heute sogar aktualisiert. Der Gaming PC benutzt ja keine Elgato, deswegen denke ich nicht das es an der Elgato liegt. - HD60S ist an USB3.0 angeschlossen.

    Das Bild ist am Gaming PC sowie am Streaming PC schlecht, also wenn ich den Stream über den Gaming PC starte dann ist es genau das selbe :(

    An meinem internet kann es unmöglich liegen, OBS hat 6000kb/s Bitrate und die sind auch voll da ohne verlorene Frames.
  • VOD = Video on demand
    Guck dir einfach mal deine aufgezeichneten Videos auf Twitch an. Wenn’s da läuft, passt es in der Regel und wird nur bei dir kacke angezeigt. Passiert leider gelegentlich.

    Ansonsten sind 6000 kbit natürlich nicht der Kracher. So ganz neutral betrachtet ist das quasi DVD-Qualität. Wenn man die beste Qualität beim Streamen will, ist man bei Twitch falsch. YouTube lässt beispielsweise höhere Bitraten zu. Aber das ist ein anderes Thema. An gelegentlichen Pixelmatsch muss man sich da halt gewöhnen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Game of Jones ()

  • Diakota habe es heute auf einem 2. Kanal getestet deswegen wirst du es dort nicht finden.
    Leider keine Aufnahmen gespeichert, ich werde es mal probieren morgen und dann sehen wir weiter denke ich.


    6000kb/s sind trotzdem das Maximal was man für normale Twitch-streamer haben kann, also eigentlich doch ganz gut.
  • Irgendwie stellst du dich grad bisschen stur an, wenn man dir helfen möchte.

    Ohne Settings können wir halt nicht sehen ob was falsch eingestellt ist. Und wenn du meinst du hast alles richtig eingestellt und auch den GameMode ausgemacht und so weiter und jeden unserer Tipps ignorierst, dann weiß ich nicht, ob du jemals auf einen Punkt kommen wirst, wo du zufrieden bist.

    Da dein Streaming PC aus meinen Augen nicht zum Streamen gedacht ist, würd ich sowieso einfach mal ohne Streaming PC alles testen und einstellen. Für Fortnite sollte das reichen.
  • Klar, 6000 sind ganz gut, aber eben nicht gut und schon gar nicht schön. Die Menge würde von Twitch so gewählt, weil es ein guter Kompromiss aus Qualität und Leistung ist. Du musst halt bedenken, dass es nichts bringt, wenn dein Upload und dein Download der Kracher sind, wenn niemand sich deinen Stream ansehen kann, weil die Leitung der Zuschauer schlecht ist. Die müssen die 6000 kbps, die du uns Internet ballerst ja die ganze Zeit nochmal runterladen.

    Was ich damit sagen will: cool, wenn man mit 6000 streamen kann und die Zuschauer es sehen, aber man darf sich nicht beschweren, wenn die Qualität nicht gestochen scharf ist, das Bild leicht verschwommen und man immer mal wieder Fragmente hat. Die Bitrate ist halt keine gute Voraussetzung für HD/Full-HD-Bild. Für Live-Formate aber vertretbar. Sieht ja nicht schrecklich aus und letztlich steht eh die Unterhaltung im Vordergrund.


  • schau dir hier mal die verpixelte kamera + spiel an bei bewegung..

    Dungi vielleicht hast du recht weil ich alles schon probiert habe..
    Wie du sagst, ich soll es ohne Streaming PC probieren. Hatte es mit meinem Gaming PC gemacht und exakt das selbe problem gehabt und der hat einen i7 drin und eine 1070.
    Ich sende später einmal die einstellungen rein
  • Korrigiert mich, wenn ich falsch liege, aber für mich sieht da nur das Bild der Webcam schlecht aus, das Spiel ist gestochen scharf für die Verhältnisse, die machbar sind und auch die Farben sehen gut aus. Mir ist bis jetzt nicht klar, was dein Problem ist und was behoben werden soll. Im Text steht Bild, die Rede ist von allem möglichen und auf dem Video sehr ich nur die Webcam als Problem. Du musst uns schon erklären, was genau das Problem ist, dann helfen wir auch gern.

    Ich sag’s gern wieder: die Settings wären interessant.
    Welches Modell? Welche Treiber? Welche Einstellungen? Welche Filter? Alles, was man so an Infos geben kann.

    Stecker raus, Treiber deinstallieren, Stecker rein. Probieren. Wenn immer noch schlecht, Software vom Hersteller installieren.

    Falls es eine C920/922 ist: BEIDE Treiber installieren.
    Autofokus aus! Du hast viele Objekte im sichtfeld, das verwirrt die Kamera. Außerdem Farbfilter drüber, Kontrast hoch, Helligkeit leicht runter, Sättigung leicht hoch. Die Farben sind Mist by default.
    Auflösung kannst du auf 800x600 stellen oder du gehst gleich auf HD-Ready mit 720p. Damit kriegst du dann auch die 60fps. In 1080p hat die Kamera nämlich nur 30. Beim Bild kannst du an den Seiten sogar was wegschneiden, dann hast du mehr Platz fürs Gameplay. Aber das ist nur ne persönliche Vorliebe von mir. So sieht’s auch gut aus.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Game of Jones ()

  • Ich schicke euch später alle meine Einstellungen mal rein, danke trotzdem schonmal.
    Ich hatte die c525 dort, habe mir jetzt die c922 gekauft weil ich dachte vielleicht liegt es an der Cam, aber gleiches Problem.
    Heute Abend gegen 18 Uhr kommen die Settings vom Streaming PC
  • Wenn ich mir seine Aufnahme so anschaue, sehe ich auch nur die Webcam leicht verpixelt. Das Game an sich ist gut erkennbar, ohne nennenswerte pixelbildung. Das die Cam pixelt habe ich nun schon bei vielen anderen auch gesehen, auch bei größeren Streamern. Ich selbst habe das Problem auch. Ich würde teilweise auch auf die Ausleuchtung tippen, die ist echt mieserabel und die sollte echt sein. Wenn das nicht gegeben ist, hast du bei schnellen Bildwechseln schlechtes Cambild, weil diese Stelle viel dunkler ist, als der rest und der Codierer denkt sich so "oh das ist dunkel, da kann nicht so viel zu sehen sein, also bearbeite ich die stelle nicht so krass" verstehst du was ich meine? Wie Dungi und Jones schon sagten, wichtig ist die Ausleuchtung. Das wird dir auch jeder Fotograf sagen.

    Aber...ich muss den Beiden beipflichten...so ganz ohne Settings deines Streaming PCs können wir nicht groß helfen. Wo ich allerdings die Prognose stellen kann, das er mit dem i5 3570k nicht langsamer als medium machen kann...
  • TheCrow danke für deine antwort, der Streaming PC streamt über NVENC mit einer gtx660 - die qualität war vorher sehr gut also zum Streamen reicht es locker.

    Werde heute Abend die Settings des Streaming PC‘s rein schicken.

    RE: Einstellungen des Streaming PC's im Anhang.

    Bitte schaut euch das auch an - dort sieht man es sehr gut das Kamera sowie das Gameplay selbst kriselig wird!
    Bilder
    • ausgabe.PNG

      64,99 kB, 985×781, 19 mal angesehen
    • video.PNG

      56,39 kB, 986×775, 19 mal angesehen

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von chuliencho ()

  • Ok...ich muss dich Fragen: Warum einen Streaming PC, wenn dieser über die Grafikkarte codiert? Eine Grafikkarte bearbeitet ganz anders das Bild und benötigt viel mehr Bandbreite, als der Prozessor. Mit einem guten Prozessor bekommst du ein viel sauberes Bild hin mit gleicher Bitrate als mit der Grafikkarte. Und da ist völlig egal, mit welcher Grafikkarte, du wirst immer Qualitätseinbußen haben. Das ist Fakt.

    Aber um auf meine Frage zurückzukommen: du hast in deinem Gaming PC einen i7-8700k, welcher im Bootstakt schon mi 4,7ghz läuft. Du hast eine GTX 1070, welche an sich schon gut ist. Ich selber hab auch einen i7-8700k, mit welchem ich mal testweise gestreamt habe und konnte ohne Probleme auf Medium streamen und gleichzeitig PUBG zocken, welches ziemlich CPU lastig ist. Mit deiner gtx 1070 könntest du auch locker streamen, da sie genügend Power hat, das Game und den Stream zu codieren, zumal für das codieren eines Streams ein eigener Chip zuständig ist.

    Hast du es denn schonmal versucht, mit dem i5 zu streamen? Wenn ja, welches Preset (very fast, faster, fast etc) konntest du da fahren?

    Edit:

    zumal man dazu sagen, muss Fortnite ja extrem Bunt und jede menge Details auf Bild ballert, der Codierer hat ordentlich zu tun dabei.
  • Also hatte veryfast probiert aber das selbe problem.. Ich habe es nun trotzdem mal auf x264 gestellt und mein Internet geupgraded. - demnächst sollte ich 22MB Upload haben.
    Heute versuche ich es trotzdem und streame um 19:00 Uhr.

    EDIT: Der Gaming PC mit der 1070 & i7 hat das selbe problem! Irgendwas stimmt da nicht...